Bug 155302 - [ios-sim] storage/websql tests broken after r197922
Summary: [ios-sim] storage/websql tests broken after r197922
Status: RESOLVED DUPLICATE of bug 155340
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-10 10:10 PST by Ryan Haddad
Modified: 2016-03-10 19:42 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2016-03-10 10:10:56 PST
storage/websql/database-lock-after-reload.html
storage/websql/open-database-creation-callback.html
storage/websql/open-database-expand-quota.html

<https://build.webkit.org/results/Apple%20iOS%209%20Simulator%20Release%20WK2%20(Tests)/r197939%20(3866)/results.html>

--- /Volumes/Data/slave/ios-simulator-9-release-tests-wk2/build/layout-test-results/storage/websql/database-lock-after-reload-expected.txt
+++ /Volumes/Data/slave/ios-simulator-9-release-tests-wk2/build/layout-test-results/storage/websql/database-lock-after-reload-actual.txt
@@ -1,3 +1,4 @@
-Inserting some data
-Test part 2 Complete
+CONSOLE MESSAGE: line 52: TypeError: undefined is not an object (evaluating 'database.transaction')
+Error - could not open database
+Test part 1 Complete
 
--- /Volumes/Data/slave/ios-simulator-9-release-tests-wk2/build/layout-test-results/storage/websql/open-database-creation-callback-expected.txt
+++ /Volumes/Data/slave/ios-simulator-9-release-tests-wk2/build/layout-test-results/storage/websql/open-database-creation-callback-actual.txt
@@ -1,3 +1,4 @@
+UI DELEGATE DATABASE CALLBACK: exceededDatabaseQuotaForSecurityOrigin:{file, , 0} database:OpenDatabaseCreationCallback11457630992488
 CONSOLE MESSAGE: line 56: unable to open database, version mismatch, '1.0' does not match the currentVersion of ''
 This test tests openDatabase()'s creation callback.
 
--- /Volumes/Data/slave/ios-simulator-9-release-tests-wk2/build/layout-test-results/storage/websql/open-database-expand-quota-expected.txt
+++ /Volumes/Data/slave/ios-simulator-9-release-tests-wk2/build/layout-test-results/storage/websql/open-database-expand-quota-actual.txt
@@ -1,3 +1,3 @@
 UI DELEGATE DATABASE CALLBACK: increased quota to 8000000
 This tests that calling openDatabase with a size over 5MB doesn't assert on debug builds, and will increase the quota to accommodate the requested size whennot exceeding a max limit of 10M.
-PASS
+FAIL
Comment 1 Alexey Proskuryakov 2016-03-10 19:42:04 PST

*** This bug has been marked as a duplicate of bug 155340 ***