Bug 15489 - Text layout is wrong in case of dir=RTL
Summary: Text layout is wrong in case of dir=RTL
Status: RESOLVED DUPLICATE of bug 23556
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh Intel OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: NeedsReduction
Depends on:
Blocks:
 
Reported: 2007-10-13 10:22 PDT by Yael
Modified: 2010-10-08 12:42 PDT (History)
4 users (show)

See Also:


Attachments
Reduction of this bug. (1010 bytes, text/html)
2008-10-13 15:58 PDT, Brian Ellis
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yael 2007-10-13 10:22:39 PDT
Text layout is wrong in RTL page. See e.g. http://www.debka.co.il
Comment 1 Yael 2007-10-13 10:30:49 PDT
I forgot to mention that the problem is visible only if you view the page in a small window. You cannot scroll to the left to see the rest of the page content.
Comment 2 Brian Ellis 2008-10-13 15:58:41 PDT
Created attachment 24332 [details]
Reduction of this bug.

This reduction shows the bug in a minimal test case.  With the dir attribute set to "rtl", resizing the window smaller than 600px wide will cause text to be cropped by the left edge of the window with no scroll bar available.  Changing the dir attribute to "ltr" causes a scroll bar to appear as expected when the window is resized narrower than 600px.
Comment 3 Yair Yogev 2009-04-15 15:16:06 PDT
this is now Bug 23556 i think
https://bugs.webkit.org/show_bug.cgi?id=23556
Comment 4 Xiaomei Ji 2010-10-08 12:42:17 PDT

*** This bug has been marked as a duplicate of bug 23556 ***