Bug 15486 - REGRESSION: Reload causes WebKit to *forget* fragment URLs
Summary: REGRESSION: Reload causes WebKit to *forget* fragment URLs
Status: RESOLVED DUPLICATE of bug 3580
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: HasReduction, InRadar, Regression
Depends on:
Blocks: 15554
  Show dependency treegraph
 
Reported: 2007-10-12 23:16 PDT by Eric Seidel (no email)
Modified: 2008-04-03 22:15 PDT (History)
2 users (show)

See Also:


Attachments
test case (1.91 KB, text/html)
2007-10-12 23:27 PDT, Eric Seidel (no email)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2007-10-12 23:16:32 PDT
Reload causes WebKit to *forget* fragment URLs

See attached test case.  Notice how the behavior is different when the page is first loaded (or loaded by hitting enter in the url bar, or dropping the file onto Safari) than when you hit "reload".  Specifically the urls lose all of their fragments on reload!
Comment 1 Eric Seidel (no email) 2007-10-12 23:27:52 PDT
Created attachment 16651 [details]
test case

This actually behaves differently than my non-reduced (multi-file) test case.  I may have to re-reduce that one to something that forgets the fragments all together.  This one seems to remember them (but incorrectly!?)
Comment 2 Eric Seidel (no email) 2007-10-13 00:35:24 PDT
After further testing, this is a regression (albeit a strange one) from Safari 2.
Comment 3 Alexey Proskuryakov 2007-10-13 00:36:23 PDT
I'm surprised that pressing Enter in address bar and actually pressing Cmd+R produces different results - I thought both were supposed to perform the same action.
Comment 4 David Kilzer (:ddkilzer) 2007-11-28 23:00:02 PST
<rdar://problem/5619358>
Comment 5 Cameron Zwarich (cpst) 2008-03-21 18:43:49 PDT
(In reply to comment #3)
> I'm surprised that pressing Enter in address bar and actually pressing Cmd+R
> produces different results - I thought both were supposed to perform the same
> action.

I don't know whether they are supposed to do the same thing, but they don't. Hitting enter in the address bar will call FrameLoader::createHistoryItem(), but reloading doesn't do the same thing.
Comment 6 Cameron Zwarich (cpst) 2008-03-22 02:34:41 PDT

*** This bug has been marked as a duplicate of 3580 ***