RESOLVED FIXED 154628
Use IndentTextOrNot instead of passing isFirstLine/shouldIndentText as bool.
https://bugs.webkit.org/show_bug.cgi?id=154628
Summary Use IndentTextOrNot instead of passing isFirstLine/shouldIndentText as bool.
zalan
Reported 2016-02-23 19:03:28 PST
In RenderBlock (availableLogicalWidthForLine etc) and through the dependencies.
Attachments
Patch (32.41 KB, patch)
2016-02-23 20:24 PST, zalan
no flags
Patch (33.44 KB, patch)
2016-02-23 20:46 PST, zalan
simon.fraser: review+
zalan
Comment 1 2016-02-23 20:24:22 PST
Created attachment 272082 [details] Patch This patch has a source dependency on bug 154019.
zalan
Comment 2 2016-02-23 20:46:24 PST
Simon Fraser (smfr)
Comment 3 2016-02-24 09:20:14 PST
Comment on attachment 272083 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=272083&action=review > Source/WebCore/rendering/RootInlineBox.cpp:724 > + LayoutUnit nextLeft = blockFlow().logicalLeftOffsetForLine(nextTop, DoNotIndentText); > + LayoutUnit nextRight = blockFlow().logicalRightOffsetForLine(nextTop, DoNotIndentText); > + LayoutUnit newLeft = blockFlow().logicalLeftOffsetForLine(selectionBottom, DoNotIndentText); > + LayoutUnit newRight = blockFlow().logicalRightOffsetForLine(selectionBottom, DoNotIndentText); Seems like DoNot is much more common; maybe make it a default parameter?
Myles C. Maxfield
Comment 4 2016-02-24 09:55:30 PST
Comment on attachment 272083 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=272083&action=review > Source/WebCore/rendering/RenderBlock.h:125 > + LayoutUnit availableLogicalWidthForLineInRegion(LayoutUnit position, IndentTextOrNot shouldIndentText, RenderRegion* region, LayoutUnit logicalHeight = 0) const I dislike names with "OrNot." How about ShouldIndentText? ShouldIndent? IndentionRequired?
zalan
Comment 5 2016-03-02 13:42:13 PST
zalan
Comment 6 2016-03-02 13:45:14 PST
(In reply to comment #4) > Comment on attachment 272083 [details] > Patch > > View in context: > https://bugs.webkit.org/attachment.cgi?id=272083&action=review > > > Source/WebCore/rendering/RenderBlock.h:125 > > + LayoutUnit availableLogicalWidthForLineInRegion(LayoutUnit position, IndentTextOrNot shouldIndentText, RenderRegion* region, LayoutUnit logicalHeight = 0) const > > I dislike names with "OrNot." How about ShouldIndentText? ShouldIndent? > IndentionRequired? I dislike it very much too, but i'd rather have it in a follow-up patch.
Note You need to log in before you can comment on or make changes to this bug.