Bug 15460 - REGRESSION: Dragging a link or an image from an IFrame causes the page to not respond to clicks afterwards
Summary: REGRESSION: Dragging a link or an image from an IFrame causes the page to not...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Frames (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://wolfire.com/webkitbug.html
Keywords: HasReduction, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-10-10 16:57 PDT by Jeffrey Rosen
Modified: 2010-10-04 04:55 PDT (History)
4 users (show)

See Also:


Attachments
Test page for easy future reference. (652 bytes, text/html)
2010-10-01 03:41 PDT, Adrian Sutton
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeffrey Rosen 2007-10-10 16:57:57 PDT
If you drag a link or image from an IFrame, you will no longer be able to click on links on the container page until you click somewhere back in the iframe you were dragging from.  See URL, for an easy test case.
Comment 1 Alexey Proskuryakov 2007-10-11 01:00:47 PDT
This is a regression from Tiger Safari/WebKit.
Comment 2 David Kilzer (:ddkilzer) 2007-10-12 05:07:05 PDT
<rdar://problem/5537289>
Comment 3 Oliver Hunt 2007-11-12 20:02:00 PST
Fix landed r27742
Comment 4 Oliver Hunt 2007-12-14 15:34:10 PST
Jeffrey could you verify this with a nightly?
Cheers
Comment 5 Adrian Sutton 2010-10-01 03:41:10 PDT
This issue appears to have regressed again.  The original test page has disappeared but I've put a new simple test case at:
http://symphonious.net/bugs/dragAndClick.html
Comment 6 Adrian Sutton 2010-10-01 03:41:41 PDT
Created attachment 69444 [details]
Test page for easy future reference.
Comment 7 Alexey Proskuryakov 2010-10-01 17:18:58 PDT
Could you please file a new bug? It's obviously a different issue (since the original has been fixed years ago), and it's very confusing to track several issues in ones bug.

In the new bug, please describe what you are doing in some more detail - I couldn't reproduce it in Safari on Mac OS X, probably due to doing something slightly differently.
Comment 8 Adrian Sutton 2010-10-04 04:55:14 PDT
Thanks for the reply Alexey,
I don't have access to the original test case, but to me the description fits exactly what I'm seeing, hence suggesting this bug has regressed again rather than opening a new one.

In any case, while I can reproduce the issue on the latest Safari and Chrome, I can't reproduce it on the latest WebKit nightly so it appears to have been fixed again. My apologies for not thinking to test the latest nightly earlier.