Bug 154592 - B3::Value doesn't self-destruct virtually enough (Causes many leaks in LowerDFGToB3::appendOSRExit)
Summary: B3::Value doesn't self-destruct virtually enough (Causes many leaks in LowerD...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Filip Pizlo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-23 10:15 PST by Alexey Proskuryakov
Modified: 2016-02-23 19:16 PST (History)
7 users (show)

See Also:


Attachments
leaks screenshot (476.57 KB, image/png)
2016-02-23 10:16 PST, Alexey Proskuryakov
no flags Details
the patch (3.12 KB, patch)
2016-02-23 13:39 PST, Filip Pizlo
sbarati: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2016-02-23 10:15:20 PST
Looking at leaks bot output, I noticed that our biggest leaks (aside from an old well known forms one) happen in LowerDFGToB3::appendOSRExit.

https://build.webkit.org//LeaksViewer/?url=%2Fresults%2FApple%20El%20Capitan%20%28Leaks%29%2Fr196979%20%283155%29%2F
Comment 1 Alexey Proskuryakov 2016-02-23 10:16:09 PST
Created attachment 272029 [details]
leaks screenshot
Comment 2 Filip Pizlo 2016-02-23 10:53:42 PST
Looking at this now.
Comment 3 Filip Pizlo 2016-02-23 13:18:15 PST
I can repro the leak by just looking at V8Spider/crypto.  I'm hunting for the cause now...
Comment 4 Filip Pizlo 2016-02-23 13:22:10 PST
This bug is because I didn't know how to call a virtual destructor.

Patch on the way!
Comment 5 Filip Pizlo 2016-02-23 13:39:15 PST
Created attachment 272047 [details]
the patch
Comment 6 Filip Pizlo 2016-02-23 14:17:41 PST
Landed in http://trac.webkit.org/changeset/196996
Comment 7 Alexey Proskuryakov 2016-02-23 19:16:05 PST
Confirmed that it's all fixed. Thank you!