Bug 15459 - Flash content grabs mouse pointer when it is hovering above Safari chrome (status bar, scroll bars, tabs)
Summary: Flash content grabs mouse pointer when it is hovering above Safari chrome (st...
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh Intel OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction, InRadar
Depends on:
Blocks:
 
Reported: 2007-10-10 16:09 PDT by Ain Tohvri
Modified: 2010-01-22 05:54 PST (History)
3 users (show)

See Also:


Attachments
Pointer on the tab (35.84 KB, image/png)
2007-10-10 16:10 PDT, Ain Tohvri
no flags Details
Page renders through the tabs (33.67 KB, image/png)
2007-10-31 04:56 PDT, Ain Tohvri
no flags Details
Test case (download and extract) (35.31 KB, application/zip)
2007-10-31 10:32 PDT, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ain Tohvri 2007-10-10 16:09:38 PDT
Occasionally in cases where you've got multiple tabs in a browser and underneath a tab is a certain link (not just any link), it changes a mouse cursor into a pointer (see the screenshot).

I found this while moving around Google Analytics. Left link block there seems to bring that issue up nicely.
Comment 1 Ain Tohvri 2007-10-10 16:10:28 PDT
Created attachment 16619 [details]
Pointer on the tab
Comment 2 Ain Tohvri 2007-10-10 16:35:30 PDT
Deleting preferences seems to resolve the weirdness
Comment 3 Ain Tohvri 2007-10-31 04:55:04 PDT
The issue is there for the latest nightly
Comment 4 Ain Tohvri 2007-10-31 04:56:03 PDT
Created attachment 16964 [details]
Page renders through the tabs
Comment 5 Ain Tohvri 2007-10-31 04:58:51 PDT
Comment on attachment 16964 [details]
Page renders through the tabs

You can see the Analytics Site Usage area there (Flash) that follows the cursor movement on tabs.

It only happens if the particular Flash area is behind the tabs.
Comment 6 Ain Tohvri 2007-10-31 05:00:21 PDT
Deleting the preference lists for both Safari and WebKit didn't make any difference
Comment 7 David Kilzer (:ddkilzer) 2007-10-31 10:16:49 PDT
This sound very familiar.  Does it happen when the Flash content is behind a vertical or horizontal scrollbar as well?

May be related to this radar:  <rdar://problem/5361894>
Comment 8 David Kilzer (:ddkilzer) 2007-10-31 10:30:07 PDT
Actually, Flash is able to grab the mouse pointer above any of the following Safari chrome:

- vertical scroll bar
- horizontal scroll bar
- status bar (must be turned on)
- resize thumb (lower right-hand corner of the window)
- tab bar
- bookmarks bar (only the bottom half of its height)
Comment 9 David Kilzer (:ddkilzer) 2007-10-31 10:32:59 PDT
Created attachment 16967 [details]
Test case (download and extract)

You may need to change the height of the <div> elements and resize your browser window to make certain Safari chrome elements render "over" the Flash content, but the way this Flash ad works, it hides the mouse pointer, causing very odd behavior.
Comment 10 David Kilzer (:ddkilzer) 2007-10-31 10:33:18 PDT
<rdar://problem/5361894>
Comment 11 David Kilzer (:ddkilzer) 2007-10-31 10:34:59 PDT
Not sure if this bug is in Safari or WebKit.  May be a combination of both (since WebKit draws the scroll bars, but Safari draws the other elements).

Comment 12 Ain Tohvri 2010-01-22 03:41:17 PST
Looks like the issue has been addressed in Safari 4.0.4.

It works for me on the latest nightly, version 4.0.4 (6531.21.10, r53677). Please confirm.
Comment 13 David Kilzer (:ddkilzer) 2010-01-22 05:51:16 PST
(In reply to comment #12)
> Looks like the issue has been addressed in Safari 4.0.4.
> 
> It works for me on the latest nightly, version 4.0.4 (6531.21.10, r53677).
> Please confirm.

I concur that this has been fixed in Safari 4.0.4.
Comment 14 David Kilzer (:ddkilzer) 2010-01-22 05:54:02 PST
(In reply to comment #13)
> (In reply to comment #12)
> > Looks like the issue has been addressed in Safari 4.0.4.
> > 
> > It works for me on the latest nightly, version 4.0.4 (6531.21.10, r53677).
> > Please confirm.
> 
> I concur that this has been fixed in Safari 4.0.4.

Actually I think this was fixed by Flash 10 rather than Safari 4.0.4.