Bug 15454 - CSS @font-face rules don't work on PPC Macs
Summary: CSS @font-face rules don't work on PPC Macs
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-10 13:36 PDT by Olaf Pluta
Modified: 2007-10-16 09:21 PDT (History)
3 users (show)

See Also:


Attachments
Test case (522 bytes, text/html)
2007-10-11 10:32 PDT, David Kilzer (:ddkilzer)
no flags Details
Working test case (524 bytes, text/html)
2007-10-16 09:21 PDT, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf Pluta 2007-10-10 13:36:35 PDT
While the new Webkit support for CSS @font-face rules works nicely on my MacBook Pro (Intel Core Duo), it does not work at all on my Power Mac G4 Cube. I used the latest nightly build 26183 on both machines (which both run Mac OS X 10.4.10).
Comment 1 Olaf Pluta 2007-10-10 13:53:07 PDT
I used the following W3C example (slightly modified with respect to the font used):

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">
<HTML>
  <HEAD>
    <TITLE>Font test</TITLE>
    <STYLE TYPE="text/css" MEDIA="screen, print">
      @font-face {
        font-family: "WeissRundgotisch";
        src: url("http://site/WeissRundgotisch.ttf") format ("truetype");
      }
      H1 { font-family: "WeissRundgotisch", serif }
    </STYLE>
  </HEAD>
  <BODY>
    <H1> This heading is displayed using WeissRundgotisch. </H1>
  </BODY>
</HTML>

The heading is displayed correctly in WeissRundgotisch on my MacBook Pro (Intel), but not on my Power Mac G4 Cube (PPC).
Comment 2 Dave Hyatt 2007-10-10 14:09:40 PDT
Wow, odd.
Comment 3 mitz 2007-10-10 14:30:34 PDT
(In reply to comment #1)
>         src: url("http://site/WeissRundgotisch.ttf") format ("truetype");

I couldn't test with your example because of the above bogus URL, but the examples linked from <http://www.alistapart.com/articles/cssatten> work for me on an iMac G5 running Mac OS X 10.4.10 and the nightly build of the feature branch at r26183.
Comment 4 Olaf Pluta 2007-10-10 14:46:20 PDT
I tested all three examples in the article "CSS @ Ten: The Next Big Thing" by HÅKON WIUM LIE <http://www.alistapart.com/articles/cssatten>, but none of them worked on my Power Mac G4 Cube (running Mac OS X 10.4.10 and the nightly build of the feature branch at r26183). Very strange, indeed.
Comment 5 Olaf Pluta 2007-10-10 14:55:16 PDT
Additional Information: While I use Mac OS X 10.4.10 Client on my MacBook Pro, the Power Mac G4 Cube is running Mac OS X 10.4.10 Server. I don't know if this detail is crucial to reproduce this bug. (During the weekend, I will have access to a Power Mac G4 Cube running Mac OS X 10.4.10 Client.)
Comment 6 mitz 2007-10-10 15:01:28 PDT
Olaf, do you have any third-party font management software installed on the PowerPC machine?
Comment 7 Olaf Pluta 2007-10-10 15:26:48 PDT
The G4 Cube is running as a bare-bones Web server. Apart from Apple's own Font Book, no font-related software is installed on this machine.
Comment 8 Alexey Proskuryakov 2007-10-11 00:52:01 PDT
When I looked at <http://www.alistapart.com/articles/cssatten> from my G4, the examples did work, but I got a crash in rendering code at some point. I haven't been able to reproduce it, and it's probably unrelated to the problem Olaf is seeing, but I guess I should post my results for an additional data point.

Thread 0 Crashed:
0   com.apple.WebCore        	0x0117174c WebCore::RenderObject::setNeedsLayout(bool, bool) + 28
1   com.apple.WebCore        	0x014d1000 WebCore::CSSFontSelector::fontLoaded(WebCore::CSSFontFace*) + 96
2   com.apple.WebCore        	0x014d0208 WebCore::CachedFont::checkNotify() + 88
3   com.apple.WebCore        	0x0111621c WebCore::Loader::didFinishLoading(WebCore::SubresourceLoader*) + 364

Comment 9 David Kilzer (:ddkilzer) 2007-10-11 10:17:57 PDT
Olaf, are you sure you have the *exact* same font file on both systems?  Running "cksum" from the Terminal on each file should give you a hash that's identical.

Have you tried this with any other fonts?  Do they all not work, or is it just this one?

When I searched Google for "WeissRundgotisch font", there were only 7 hits, and most of the hits included an ® (R) symbol in the name and a spaces betwen "Weiss" and "Rundgotisch".  I wonder if this has any significance?

http://www.google.com/search?client=safari&q=WeissRundgotisch+font

BTW, please do not post the font to this bug as that will violate copyright laws.  If you could reproduce this on a available free font (that others could download to test), that would be even better.

Comment 10 David Kilzer (:ddkilzer) 2007-10-11 10:32:40 PDT
Created attachment 16631 [details]
Test case

Test case based on examples from <http://www.alistapart.com/articles/cssatten>.

These do not work on my PowerBook G4.  :(

Tested using WebKit Nightly r26359 with Safari 3 Public Beta v. 3.0.3 (522.12.1).
Comment 11 David Kilzer (:ddkilzer) 2007-10-11 10:33:06 PDT
(In reply to comment #10)
> These do not work on my PowerBook G4.  :(
> 
> Tested using WebKit Nightly r26359 with Safari 3 Public Beta v. 3.0.3
> (522.12.1).

Running Mac OS X 10.4.10 (8R218).

Comment 12 Olaf Pluta 2007-10-11 10:41:51 PDT
There is a single font file (WeissRundgotisch.ttf) on one of my Web servers. Using the @font-face rules, Webkit should fetch this front from the specified URL and use it when rendering the Website.

The font is available as a free download at:
http://moorstation.org/typoasis/designers/steffmann/samples/w/weiss_rund.htm

Since the examples in <http://www.alistapart.com/articles/cssatten> are not displayed correctly as well, the problem is not related to a single font.
Comment 13 Olaf Pluta 2007-10-11 12:31:51 PDT
The problem persists with the nightly build 26359 of Webkit. All three examples in <http://www.alistapart.com/articles/cssatten> don't work on my Power Mac G4 Cube running Mac OS X Server v10.4.10. (Actually, I tested it on two G4 Cubes which both run as Web servers, and it's the same problem on both machines.)

I am very much looking forward to having this work on all Macs (including the older PPC-based machines). The implementation of the @font-face rules is a major achievement, and I sincerely hope that this feature will make it into the final release of Safari 3 (and ultimately into Mobile Safari on the iPhone).
Comment 14 Olaf Pluta 2007-10-12 13:04:57 PDT
All three examples in <http://www.alistapart.com/articles/cssatten> don't work on the following machines:

(1) iBook (500 MHz PowerPC G3) running Mac OS X 10.4.10 (Client)
(2) Power Mac G4 Cube (500 MHz PowerPC G4) running Mac OS X 10.4.10 (Client)
(3) Power Mac G4 Cube (500 MHz PowerPC G4) running Mac OS X 10.4.10 (Server)

I used the latest nightly build 26359 of Webkit for these tests.
Comment 15 Olaf Pluta 2007-10-16 06:58:09 PDT
It turns out that I did not download the latest nightly build of the "feature branch" on my PowerPC-based Macs, but somehow managed to download the "trunk" version. With the latest nightly build (r26359) of the feature branch of WebKit in place, the @font-face rules work nicely on my G4 Cubes. My apologies for the false alarm.
Comment 16 David Kilzer (:ddkilzer) 2007-10-16 09:21:55 PDT
Created attachment 16685 [details]
Working test case

Goodfish did not show up in the other test case, so I'm uploading this one for posterity.

This works for me now as well with r26602.  I'm not sure why I thought this feature was on trunk when the feature-branch existed.