Bug 15452 - REGRESSION: two tabs required to move between links containing <object>
Summary: REGRESSION: two tabs required to move between links containing <object>
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://www.peepo.com
Keywords: HasReduction, Regression
Depends on:
Blocks:
 
Reported: 2007-10-10 10:20 PDT by jay
Modified: 2008-07-28 01:53 PDT (History)
1 user (show)

See Also:


Attachments
link off site? (878 bytes, text/html)
2007-10-10 10:53 PDT, jay
no flags Details
html-only test case (503 bytes, text/html)
2007-10-18 02:35 PDT, Eric Seidel (no email)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description jay 2007-10-10 10:20:27 PDT
visit the URI, and use keyboard to navigate. in opera or mozilla, one tab per link navigates the whole page.
in safari one has to hit the tab key twice per link...

I am pretty certain this is a regression though it's been around for quite some time.

SVG may not be the right component, so please move...

in fact just now opera nightly has a bug and keyboard navigation is broken...
Comment 1 jay 2007-10-10 10:53:01 PDT
Created attachment 16614 [details]
link off site?
Comment 2 Eric Seidel (no email) 2007-10-10 11:46:08 PDT
This appears to be a real bug.  I would start debugging here:
void EventHandler::defaultTabEventHandler(Event* event, bool isBackTab)

The bug relates to the presence of the <object> tag, I expect that the object is stealing focus when it should not be, but I haven't yet confirmed what element is getting the focus when the <a> loses it.
Comment 3 Eric Seidel (no email) 2007-10-10 11:50:01 PDT
Actually, the second event just seems to be dropped on the floor.
Comment 4 Eric Seidel (no email) 2007-10-18 02:34:40 PDT
This is definitely a regression.  I've demonstrated it with just HTML now.
Comment 5 Eric Seidel (no email) 2007-10-18 02:35:14 PDT
Created attachment 16720 [details]
html-only test case
Comment 6 Alexey Proskuryakov 2008-07-28 01:53:51 PDT
I cannot reproduce this with r35406.