Bug 154159 - [GTK] HTTP auth dialog incorrectly rendered with Accelerated Compositing enabled
Summary: [GTK] HTTP auth dialog incorrectly rendered with Accelerated Compositing enabled
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Local Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 154066
  Show dependency treegraph
 
Reported: 2016-02-12 01:01 PST by Carlos Garcia Campos
Modified: 2016-02-12 08:40 PST (History)
7 users (show)

See Also:


Attachments
Patch (3.57 KB, patch)
2016-02-12 02:57 PST, Carlos Garcia Campos
mcatanzaro: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2016-02-12 01:01:33 PST
It's blurry, the check button is rendered as a black box, there are some black borders around entries and button, and the web view background gray effect doesn't work either.
Comment 1 Carlos Garcia Campos 2016-02-12 01:48:09 PST
I still don't know what the problem is, but I'm thinking that maybe we could convert the HTTP auth dialog into a PageOverlay.
Comment 2 Carlos Garcia Campos 2016-02-12 01:55:57 PST
I've just realized that this is not a problem of the threaded compositor, but exactly the same happens if you run without threaded compositor but forxing AC mode always on (WEBKIT_FORCE_COMPOSITING_MODE). So, is the threaded compositor forcing AC mode always?
Comment 3 Carlos Garcia Campos 2016-02-12 02:55:32 PST
There are two problems here, first we are changing the cairo operator when rendering the xcomposite window pixmap without a proper save/restore, so it affects the drawing that happens after that, and second problem is tyhat we are not rendering the gray background in AC mode. I'll submit a patch.
Comment 4 Carlos Garcia Campos 2016-02-12 02:57:23 PST
Created attachment 271156 [details]
Patch
Comment 5 WebKit Commit Bot 2016-02-12 02:59:17 PST
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 6 Gwang Yoon Hwang 2016-02-12 03:06:38 PST
Comment on attachment 271156 [details]
Patch

I love this patch :).
Comment 7 Michael Catanzaro 2016-02-12 08:00:52 PST
Comment on attachment 271156 [details]
Patch

rs=me with Yoon's approval
Comment 8 Carlos Garcia Campos 2016-02-12 08:40:23 PST
Committed r196475: <http://trac.webkit.org/changeset/196475>