Bug 154118 - WebContent process crashes when performing data detection on content with existing data detector links
Summary: WebContent process crashes when performing data detection on content with exi...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Enrica Casucci
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-02-11 11:18 PST by Enrica Casucci
Modified: 2016-02-22 15:12 PST (History)
2 users (show)

See Also:


Attachments
Patch (3.79 KB, patch)
2016-02-11 11:24 PST, Enrica Casucci
thorton: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Enrica Casucci 2016-02-11 11:18:40 PST
Loading content that has existing data detector links causes the WebProcess to crash.
The DOM mutation caused by removing the existing links, can shift the range endpoints.

rdar://problem/24511860
Comment 1 Enrica Casucci 2016-02-11 11:24:06 PST
Created attachment 271069 [details]
Patch
Comment 2 Tim Horton 2016-02-11 14:09:13 PST
Comment on attachment 271069 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=271069&action=review

> Source/WebCore/ChangeLog:8
> +

Where's the test!

> Source/WebCore/editing/cocoa/DataDetection.mm:529
> +        // Store the range boundaries as Position, in case the DOM changes if we find
> +        // old data detector link.

This comment has slightly weird grammar towards the end.
Comment 3 Enrica Casucci 2016-02-11 15:04:21 PST
Committed revision 196445.