Bug 154111 - Subpixel rendering: Make focusring painting subpixel aware.
Summary: Subpixel rendering: Make focusring painting subpixel aware.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: zalan
URL:
Keywords:
: 132001 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-11 09:34 PST by zalan
Modified: 2016-03-15 02:34 PDT (History)
5 users (show)

See Also:


Attachments
Patch (34.48 KB, patch)
2016-02-11 09:49 PST, zalan
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews103 for mac-yosemite (953.68 KB, application/zip)
2016-02-11 10:40 PST, Build Bot
no flags Details
Archive of layout-test-results from ews107 for mac-yosemite-wk2 (850.95 KB, application/zip)
2016-02-11 10:45 PST, Build Bot
no flags Details
Archive of layout-test-results from ews115 for mac-yosemite (989.91 KB, application/zip)
2016-02-11 11:05 PST, Build Bot
no flags Details
Patch (41.66 KB, patch)
2016-02-11 13:12 PST, zalan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description zalan 2016-02-11 09:34:34 PST
We should be able to paint focusring on a subpixel position.
Comment 1 zalan 2016-02-11 09:49:34 PST
Created attachment 271060 [details]
Patch
Comment 2 Build Bot 2016-02-11 10:40:21 PST
Comment on attachment 271060 [details]
Patch

Attachment 271060 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/815602

New failing tests:
accessibility/image-link.html
accessibility/mac/document-links.html
accessibility/table-sections.html
accessibility/table-cells.html
accessibility/table-with-rules.html
accessibility/mac/aria-columnrowheaders.html
accessibility/table-attributes.html
Comment 3 Build Bot 2016-02-11 10:40:24 PST
Created attachment 271065 [details]
Archive of layout-test-results from ews103 for mac-yosemite

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews103  Port: mac-yosemite  Platform: Mac OS X 10.10.5
Comment 4 Build Bot 2016-02-11 10:45:41 PST
Comment on attachment 271060 [details]
Patch

Attachment 271060 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/815609

New failing tests:
accessibility/image-link.html
accessibility/mac/document-links.html
accessibility/table-with-rules.html
accessibility/table-cells.html
accessibility/table-sections.html
accessibility/mac/aria-columnrowheaders.html
accessibility/table-attributes.html
Comment 5 Build Bot 2016-02-11 10:45:43 PST
Created attachment 271066 [details]
Archive of layout-test-results from ews107 for mac-yosemite-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews107  Port: mac-yosemite-wk2  Platform: Mac OS X 10.10.5
Comment 6 Build Bot 2016-02-11 11:05:32 PST
Comment on attachment 271060 [details]
Patch

Attachment 271060 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/815618

New failing tests:
accessibility/image-link.html
accessibility/mac/document-links.html
js/duplicate-param-gc-crash.html
accessibility/table-with-rules.html
accessibility/table-cells.html
accessibility/table-sections.html
accessibility/mac/aria-columnrowheaders.html
accessibility/table-attributes.html
Comment 7 Build Bot 2016-02-11 11:05:34 PST
Created attachment 271068 [details]
Archive of layout-test-results from ews115 for mac-yosemite

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews115  Port: mac-yosemite  Platform: Mac OS X 10.10.5
Comment 8 Dave Hyatt 2016-02-11 11:09:03 PST
Comment on attachment 271060 [details]
Patch

r=me, I am assuming the failures just need rebaselines.
Comment 9 zalan 2016-02-11 13:12:08 PST
Created attachment 271077 [details]
Patch
Comment 10 WebKit Commit Bot 2016-02-11 14:15:46 PST
Comment on attachment 271077 [details]
Patch

Clearing flags on attachment: 271077

Committed r196439: <http://trac.webkit.org/changeset/196439>
Comment 11 WebKit Commit Bot 2016-02-11 14:15:50 PST
All reviewed patches have been landed.  Closing bug.
Comment 12 Jon Lee 2016-03-15 02:34:30 PDT
*** Bug 132001 has been marked as a duplicate of this bug. ***