Bug 154093 - Web Inspector: Switching actions in Edit Breakpoint popover causes a jerk
Summary: Web Inspector: Switching actions in Edit Breakpoint popover causes a jerk
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Matt Baker
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-02-10 15:39 PST by Matt Baker
Modified: 2016-02-10 16:32 PST (History)
8 users (show)

See Also:


Attachments
[Patch] Proposed Fix (1.49 KB, patch)
2016-02-10 15:42 PST, Matt Baker
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Baker 2016-02-10 15:39:40 PST
* SUMMARY
Switching actions in Edit Breakpoint popover causes a jerk.

* STEPS TO REPRODUCE
1. Set a breakpoint, Edit Breakpoint to bring up dialog
2. Click Add Action. Log Message is the default.
3. Change action type to Evaluate JavaScript
  => Input field height changes and Automatically Continue checkbox position changes by a few pixels

* NOTES
This is due to different padding rules for the vanilla input field and CodeMirror editor, and User Agent margin styles applied to the input field.
Comment 1 Radar WebKit Bug Importer 2016-02-10 15:40:03 PST
<rdar://problem/24597869>
Comment 2 Matt Baker 2016-02-10 15:42:25 PST
Created attachment 271036 [details]
[Patch] Proposed Fix
Comment 3 WebKit Commit Bot 2016-02-10 16:32:19 PST
Comment on attachment 271036 [details]
[Patch] Proposed Fix

Clearing flags on attachment: 271036

Committed r196404: <http://trac.webkit.org/changeset/196404>
Comment 4 WebKit Commit Bot 2016-02-10 16:32:22 PST
All reviewed patches have been landed.  Closing bug.