Bug 153921 - [GTK][Mac] WebCore::FontCache::lastResortFallbackFont WebKitWebProcess Segfault
Summary: [GTK][Mac] WebCore::FontCache::lastResortFallbackFont WebKitWebProcess Segfault
Status: RESOLVED DUPLICATE of bug 141432
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Local Build
Hardware: Macintosh OS X 10.11
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 126492 153093
  Show dependency treegraph
 
Reported: 2016-02-05 10:36 PST by Ethan Sherriff
Modified: 2016-02-07 09:08 PST (History)
3 users (show)

See Also:


Attachments
Crash report for WebKitWebProcess (60.49 KB, text/plain)
2016-02-05 10:36 PST, Ethan Sherriff
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ethan Sherriff 2016-02-05 10:36:20 PST
Created attachment 270753 [details]
Crash report for WebKitWebProcess

Running MiniBrowser on a source build of WebKitGTK+ 2.10.7 on OS X 10.11 causes WebKitWebProcess to crash.
Comment 1 Jeremy Huddleston Sequoia 2016-02-05 12:20:23 PST
Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libwebkit2gtk-4.0.37.dylib    	0x0000000107eea634 WebCore::FontCache::lastResortFallbackFont(WebCore::FontDescription const&) + 148
1   libwebkit2gtk-4.0.37.dylib    	0x0000000107590824 WebCore::CSSFontFaceSource::font(WebCore::FontDescription const&, bool, bool, WebCore::CSSFontSelector*) + 596
2   libwebkit2gtk-4.0.37.dylib    	0x000000010758f6bf WebCore::CSSFontFace::font(WebCore::FontDescription const&, bool, bool) + 255


Can you disassemble WebCore::FontCache::lastResortFallbackFont, so we can see what is going on at that point?
Comment 2 Ethan Sherriff 2016-02-05 12:31:21 PST
Sure, I'm quite new to this sort of stuff, how would I go about doing that?
Comment 3 Ethan Sherriff 2016-02-06 13:52:41 PST
Could this be related to bug 141432, it seems similar but it's pretty a ancient bug.
Comment 4 Michael Catanzaro 2016-02-06 18:59:46 PST
It has to be at least related, because that function is pretty simple.

I guess you have a problem with fontconfig, such that it cannot find any serif font. Crashing is the right thing to do in that case, but we should still handle it better
Comment 5 Ethan Sherriff 2016-02-07 03:07:57 PST
Fixed it! Reinstalling fontconfig with the configure option:

    --with-add-fonts="/Library/Fonts,/System/Library/Fonts,/Network/Library/Fonts"

fixed it (credit to the maintainer of the fontconfig MacPorts port).
Comment 6 Jeremy Huddleston Sequoia 2016-02-07 08:23:22 PST
Can you please reopen this to add an informative release assertion here instead of crashing?
Comment 7 Ethan Sherriff 2016-02-07 08:32:56 PST
Sure, how would I do that?
Comment 8 Michael Catanzaro 2016-02-07 09:08:24 PST
See bug #141432

*** This bug has been marked as a duplicate of bug 141432 ***