Bug 153885 - [iOS Simulator] WebCoreNSURLSessionTest API tests BasicOperation and InvalidateEmpty failing
Summary: [iOS Simulator] WebCoreNSURLSessionTest API tests BasicOperation and Invalida...
Status: RESOLVED DUPLICATE of bug 153900
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: iPhone / iPad iOS 9.0
: P2 Normal
Assignee: Jer Noble
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-04 12:47 PST by Ryan Haddad
Modified: 2016-02-05 23:29 PST (History)
3 users (show)

See Also:


Attachments
Patch (1.93 KB, patch)
2016-02-04 17:26 PST, Jer Noble
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2016-02-04 12:47:59 PST
[iOS Simulator] WebCoreNSURLSessionTest API tests BasicOperation and InvalidateEmpty failing

Started with <https://trac.webkit.org/changeset/196082>

<https://build.webkit.org/builders/Apple%20iOS%209%20Simulator%20Release%20WK2%20%28Tests%29/builds/2843>

Tests that failed:
  WebCoreNSURLSessionTest.BasicOperation
  WebCoreNSURLSessionTest.InvalidateEmpty
Comment 1 Jer Noble 2016-02-04 13:22:29 PST
Interesting. I'll take a look.
Comment 2 Jer Noble 2016-02-04 17:26:30 PST
Created attachment 270706 [details]
Patch
Comment 3 Alex Christensen 2016-02-04 17:30:16 PST
I also have solutions to this in https://bugs.webkit.org/show_bug.cgi?id=153900
Comment 4 Jer Noble 2016-02-04 18:20:08 PST
For the meanwhile, before the more drastic change is made to +[WebView initialize], can we r+ this to get the iOS tests unblocked?
Comment 5 Alex Christensen 2016-02-04 19:31:52 PST
If we're just trying to fix tests, I think https://bugs.webkit.org/attachment.cgi?id=270700&action=review is a better solution than adding more UIKit SPI usage.
Comment 6 Alexey Proskuryakov 2016-02-04 21:17:08 PST
Comment on attachment 270706 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=270706&action=review

> Tools/TestWebKitAPI/Tests/WebCore/WebCoreNSURLSession.mm:48
> +SOFT_LINK(UIKit, _UIApplicationLoadWebKit, void, (void), ())

If this is necessary for WebKit tests, should we do this in shared code?

The fix in https://bugs.webkit.org/show_bug.cgi?id=153900 seems preferable still, but I don't know if there is some reason why we can't do initialization in WebKit.
Comment 7 Jer Noble 2016-02-05 13:52:48 PST

*** This bug has been marked as a duplicate of bug 153900 ***