Bug 15387 - SVG unnecessarily repaints regions even if they're clipped
Summary: SVG unnecessarily repaints regions even if they're clipped
Status: RESOLVED DUPLICATE of bug 14015
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 14015
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-05 19:56 PDT by Eric Seidel (no email)
Modified: 2007-10-12 02:18 PDT (History)
0 users

See Also:


Attachments
test case (732 bytes, application/xml)
2007-10-05 19:57 PDT, Eric Seidel (no email)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2007-10-05 19:56:47 PDT
SVG unnecessarily repaints regions even if they're clipped

See attached test case.  Run Quartz Debug and turn on "flash on screen updates" to see WebKit paint too much.
Comment 1 Eric Seidel (no email) 2007-10-05 19:57:15 PDT
Created attachment 16556 [details]
test case
Comment 2 Eric Seidel (no email) 2007-10-09 00:26:55 PDT
This is basically the same as bug 14015.
Comment 3 Eric Seidel (no email) 2007-10-12 02:18:42 PDT

*** This bug has been marked as a duplicate of 14015 ***