Bug 15383 - resize: vertical does not restrict to vertical resize
Summary: resize: vertical does not restrict to vertical resize
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: data:text/html,<div style="border: so...
Keywords: InRadar
: 19170 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-10-05 15:40 PDT by Eric Seidel (no email)
Modified: 2009-06-21 13:57 PDT (History)
4 users (show)

See Also:


Attachments
Ignore movement along the non-resizing axis (5.23 KB, patch)
2009-06-21 13:52 PDT, mitz
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2007-10-05 15:40:09 PDT
resize: vertical does not restrict to vertical resize

This seems easy to fix.  It could just effectively do max-width: current width.

The example is taken from another bug I'm filing.  But you should only be able to resize the div vertically.
Comment 1 Jan Boeijink 2007-11-21 01:10:07 PST
Horizontal restriction is broken as well.
Comment 2 mitz 2008-01-10 18:24:16 PST
<rdar://problem/5682745>
Comment 3 mitz 2008-05-21 18:15:54 PDT
*** Bug 19170 has been marked as a duplicate of this bug. ***
Comment 4 Chris Suter 2008-05-28 21:15:58 PDT
It's possible to workaround this bug in some circumstances by setting setting the max-width attribute.

However, this doesn't work if you use %ages. Setting max-width to 100%, say, will cause the computed max-width to end up as none. I'm not sure if this is another bug or not.
Comment 5 mitz 2009-06-21 13:52:50 PDT
Created attachment 31620 [details]
Ignore movement along the non-resizing axis
Comment 6 mitz 2009-06-21 13:57:29 PDT
Fixed in <http://trac.webkit.org/projects/webkit/changeset/44914>.