[css-grid] Fix percentage tracks' size computation in grids with gutters
Created attachment 270567 [details] Patch
Comment on attachment 270567 [details] Patch Attachment 270567 [details] did not pass mac-debug-ews (mac): Output: http://webkit-queues.webkit.org/results/776323 New failing tests: imported/w3c/web-platform-tests/streams-api/readable-streams/garbage-collection-2.html
Created attachment 270568 [details] Archive of layout-test-results from ews113 for mac-yosemite The attached test failures were seen while running run-webkit-tests on the mac-debug-ews. Bot: ews113 Port: mac-yosemite Platform: Mac OS X 10.10.5
(In reply to comment #3) > Created attachment 270568 [details] > Archive of layout-test-results from ews113 for mac-yosemite > > The attached test failures were seen while running run-webkit-tests on the > mac-debug-ews. > Bot: ews113 Port: mac-yosemite Platform: Mac OS X 10.10.5 This is totally unrelated.
Comment on attachment 270567 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=270567&action=review The patch LGTM but I'm missing tests for rows in grid-gutters-and-tracks.html. > LayoutTests/fast/css-grid-layout/grid-gutters-and-tracks.html:23 > +.gridWithPercent { -webkit-grid-template-columns: 10px 20% repeat(2, 30px); } Weird that you're defining 4 columns and only using 3. > LayoutTests/fast/css-grid-layout/grid-gutters-and-tracks.html:26 > +.fixedSize { width: 220px; } I'll call this class "width220". > LayoutTests/fast/css-grid-layout/grid-gutters-and-tracks.html:110 > + <div class="firstRowFirstColumn sizedToGridArea" data-offset-x="0" data-offset-y="0" data-expected-width="10" data-expected-height="20"></div> I think you don't need sizedToGridArea for these items. > LayoutTests/fast/css-grid-layout/grid-gutters-and-tracks.html:135 > + <div class="firstRowFirstColumn sizedToGridArea" data-offset-x="0" data-offset-y="0" data-expected-width="132" data-expected-height="20"></div> Ditto.
Created attachment 274295 [details] Patch Now with tests for rows. Also removed sizedToGridArea class
Committed r198486: <http://trac.webkit.org/changeset/198486>