Bug 153734 - REGRESSION (r194660): Legacy WebProcess crashes in ChildProcess::initializeSandbox()
Summary: REGRESSION (r194660): Legacy WebProcess crashes in ChildProcess::initializeSa...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Local Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Daniel Bates
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-01-31 21:00 PST by mitz
Modified: 2016-02-03 08:34 PST (History)
3 users (show)

See Also:


Attachments
Patch (2.00 KB, patch)
2016-02-01 14:19 PST, Daniel Bates
no flags Details | Formatted Diff | Diff
Patch (5.83 KB, patch)
2016-02-02 17:06 PST, Daniel Bates
mitz: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2016-01-31 21:00:07 PST
After <http://trac.webkit.org/r194660>, WebProcess crashes on launch in ChildProcess::initializeSandbox, because parameters.connectionIdentifier.xpcConnection is null in a legacy process.
Comment 1 mitz 2016-01-31 21:04:14 PST
I think it is OK to simply have legacy processes always take the “Unsigned, signed by a third party, or has an invalid/malformed signature” branch.
Comment 2 Radar WebKit Bug Importer 2016-01-31 22:56:16 PST
<rdar://problem/24433179>
Comment 3 Daniel Bates 2016-02-01 14:19:08 PST
Created attachment 270425 [details]
Patch
Comment 4 Daniel Bates 2016-02-01 14:20:44 PST
I take it that we need to keep around such legacy process support?
Comment 5 Daniel Bates 2016-02-02 17:06:34 PST
Created attachment 270530 [details]
Patch
Comment 6 Daniel Bates 2016-02-03 08:34:41 PST
Committed r196066: <http://trac.webkit.org/changeset/196066>