Bug 153721 - REGRESSION(195799?): Assertion failures in InspectorTimelineAgent::didCompleteCurrentRecord
Summary: REGRESSION(195799?): Assertion failures in InspectorTimelineAgent::didComplet...
Status: RESOLVED DUPLICATE of bug 153722
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-01-30 16:23 PST by Alexey Proskuryakov
Modified: 2016-01-30 22:59 PST (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2016-01-30 16:23:38 PST
We have started seeing frequent assertion failures in InspectorTimelineAgent::didCompleteCurrentRecord a couple days ago. Not a lot of tests crash, but overall, this nearly blocks debug EWS.

E.g.:
http://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#tests=imported%2Fblink%2Fanimations%2Fbase-render-style-body-crash.html
http://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=imported%2Fblink%2Fcompositing%2Flayer-creation%2Fiframe-clip-removed.html

ASSERTION FAILED: entry.type == type
/Volumes/Data/slave/elcapitan-debug/build/Source/WebCore/inspector/InspectorTimelineAgent.cpp(520) : void WebCore::InspectorTimelineAgent::didCompleteCurrentRecord(WebCore::TimelineRecordType)
1   0x110108670 WTFCrash
2   0x1131ac270 WebCore::InspectorTimelineAgent::didCompleteCurrentRecord(WebCore::TimelineRecordType)
3   0x1131b086c WebCore::InspectorTimelineAgent::internalStart(int const*)::$_1::operator()() const
4   0x1131b077d void std::__1::__invoke_void_return_wrapper<void>::__call<WebCore::InspectorTimelineAgent::internalStart(int const*)::$_1&>(WebCore::InspectorTimelineAgent::internalStart(int const*)::$_1&&&)
Comment 1 Radar WebKit Bug Importer 2016-01-30 16:23:51 PST
<rdar://problem/24427191>
Comment 2 Alexey Proskuryakov 2016-01-30 16:25:13 PST
Let me try rolling out r195799 to let the bots check whether it's the culprit over the weekend.
Comment 3 Radar WebKit Bug Importer 2016-01-30 16:25:24 PST
<rdar://problem/24427194>
Comment 4 Alexey Proskuryakov 2016-01-30 22:59:13 PST
The rollout fixed this.

*** This bug has been marked as a duplicate of bug 153722 ***