Bug 15357 - The Gtk+ WebKit API namespace (webkit_gtk) is ugly
Summary: The Gtk+ WebKit API namespace (webkit_gtk) is ugly
Status: RESOLVED DUPLICATE of bug 14726
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: All All
: P2 Normal
Assignee: Nobody
Keywords: Gtk
Depends on:
Reported: 2007-10-03 03:23 PDT by Alp Toker
Modified: 2007-10-03 05:46 PDT (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Alp Toker 2007-10-03 03:23:29 PDT
The naming convention that has arisen for the Gtk+ WebKit public API is not very elegant or conventional.

eg. webkit_gtk_frame_new()

The _gtk component is redundant and should be removed.

eg. webkit_frame_new()

It may even be an idea to reduce webkit_ to web_ as suggested by andersca...

eg. web_frame_new()

This makes the API less verbose and also self-describing in a cute kind of way -- everyone can imagine what a "Web Frame" is.
Comment 1 Mark Rowe (bdash) 2007-10-03 03:29:14 PDT
web_ also matches the Web prefix used in the Mac API, and definitely leads to nicer sounding function names than the two alternatives that were mentioned.
Comment 2 Alp Toker 2007-10-03 05:46:40 PDT

*** This bug has been marked as a duplicate of 14726 ***