Bug 153551 - LayoutTest fast/loader/stateobjects/replacestate-frequency-iframe.html is flaky on El Cap, always times out on Yosemite.
Summary: LayoutTest fast/loader/stateobjects/replacestate-frequency-iframe.html is fla...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Macintosh Unspecified
: P2 Normal
Assignee: Brady Eidson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-27 10:06 PST by Ryan Haddad
Modified: 2016-01-27 23:17 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2016-01-27 10:06:43 PST
LayoutTest fast/loader/stateobjects/replacestate-frequency-iframe.html is flaky

This test was added with r195625, and it seems to be timing out every 2-3 runs across Mac testers.
<https://build.webkit.org/builders/Apple%20El%20Capitan%20Release%20WK2%20(Tests)/builds/2837>

<https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=fast%2Floader%2Fstateobjects%2Freplacestate-frequency-iframe.html>
Comment 1 Brady Eidson 2016-01-27 10:10:47 PST
Since the timeout case prints absolutely nothing, I cannot diagnose what may or may not be going wrong unless I can reproduce this locally (which I haven't been able to yet)
Comment 3 Brady Eidson 2016-01-27 12:28:12 PST
I've never seen a flake locally. I've run just this test 100 times in a row, and the entire directory 20 times in a row. Nothing.
Comment 4 Brady Eidson 2016-01-27 12:38:16 PST
I did notice something wrong with the test and I fixed it in http://trac.webkit.org/changeset/195687

But I don't see how that have caused the flake, or how it could resolve it.

Still exploring...
Comment 5 Brady Eidson 2016-01-27 12:45:55 PST
Wow.

The iframe url was: "resources/replaceState-iframe.html", but the file on disk is named "replacestate-iframe.html"

Notice the case sensitivity on the 'S'

Apparently some of our build bots are case sensitive and others are not, hence the flake.  :(
Comment 6 Brady Eidson 2016-01-27 12:48:06 PST
http://trac.webkit.org/changeset/195688
Comment 7 Alexey Proskuryakov 2016-01-27 23:14:35 PST
> Apparently some of our build bots are case sensitive and others are not, hence the flake.  :(

Ouch!

But unsure if that's a good or a bad thing, after all.
Comment 8 Brady Eidson 2016-01-27 23:17:46 PST
(In reply to comment #7)
> > Apparently some of our build bots are case sensitive and others are not, hence the flake.  :(
> 
> Ouch!
> 
> But unsure if that's a good or a bad thing, after all.

I think it's a good thing that we test both case sensitive and case insensitive.

I think it's a bad thing that:
A - The split was apparently accidental and unknown
B - Bots that are one or the other are not identified as such