Bug 15318 - Text fails to show up
Summary: Text fails to show up
Status: CLOSED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.adlibris.com/se/student.aspx
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-29 04:11 PDT by joppe
Modified: 2007-10-13 08:46 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description joppe 2007-09-29 04:11:28 PDT
The text in the middle doest show in the latest webkit (safari 3 too)

http://img220.imageshack.us/my.php?image=bild1qs9.png safari

http://img212.imageshack.us/my.php?image=bild2lx3.png opera
Comment 1 David Kilzer (:ddkilzer) 2007-09-29 09:42:26 PDT
This works for me using WebKit nightly WebKit-SVN-r25801.dmg with Safari 3 Public Beta v. 3.0.3 (522.12.1) on Mac OS X 10.4.10 (8R218).

Which exact version(s) of Safari and WebKit were you using?

Comment 2 Mark Rowe (bdash) 2007-09-30 05:39:40 PDT
This also works correctly for me.
Comment 3 Alexey Proskuryakov 2007-10-05 03:38:02 PDT
I cannot reproduce, too.

The Safari screenshot doesn't really look like Safari to me (note the buttons at the top left) - I presume the system appearance was altered with some hack, which could have interfered with text rendering, too.

Please re-open with additional information if this is still happens after you uninstall haxies, Safari enhancers etc.
Comment 4 David Kilzer (:ddkilzer) 2007-10-05 08:42:36 PDT
Reopening to mark RESOLVED/WORKSFORME.

Comment 5 Alexey Proskuryakov 2007-10-05 13:08:09 PDT
(In reply to comment #4)
> Reopening to mark RESOLVED/WORKSFORME.

I've marked this bug INVALID because we don't have evidence that it was ever a WebKit bug. Perhaps we need to have Bugzilla resolutions better explained somewhere :)
Comment 6 David Kilzer (:ddkilzer) 2007-10-06 06:32:55 PDT
(In reply to comment #5)
> (In reply to comment #4)
> > Reopening to mark RESOLVED/WORKSFORME.
> 
> I've marked this bug INVALID because we don't have evidence that it was ever a
> WebKit bug. Perhaps we need to have Bugzilla resolutions better explained
> somewhere :)

Actually, there is documentation here:

http://bugs.webkit.org/page.cgi?id=fields.html

I marked the bug as WORKSFORME for the exact same reason.  I think it's because I've seen far more INVALID bugs that were migrated to Radar, so I think of INVALID as being synonymous with "moved to Radar".

However, the Fields documentation above describes a "MOVED" resolution which perfectly describes the "migrated to Radar" case.  Why isn't that available?
Comment 7 Mark Rowe (bdash) 2007-10-06 06:54:06 PDT
The MOVED resolution appears to only be available when you 
Comment 8 Mark Rowe (bdash) 2007-10-06 06:55:57 PDT
... enable and use Bugzilla's "move" feature.  We don't have this enabled, and I can't see any documentation that describes how to configure it in a useful way.
Comment 9 Alexey Proskuryakov 2007-10-07 01:33:24 PDT
I mostly want to differentiate between bugs that were intentionally fixed with a check-in (FIXED) and bugs that fixed themselves (WORKSFORME). And I mark bugs that are unlikely to have ever been WebKit issues as INVALID. For this particular bug, I suspect that some Safari enhancer might be the culprit, so I closed it as INVALID.

If we stick to Bugzilla's definition of WORKFORME, then I'd suggest that we introduce a custom resolution for "definitely was a problem, but fixed itself somehow".
Comment 10 David Kilzer (:ddkilzer) 2007-10-07 16:16:49 PDT
(In reply to comment #9)
> I mostly want to differentiate between bugs that were intentionally fixed with
> a check-in (FIXED) and bugs that fixed themselves (WORKSFORME). And I mark bugs
> that are unlikely to have ever been WebKit issues as INVALID. For this
> particular bug, I suspect that some Safari enhancer might be the culprit, so I
> closed it as INVALID.

Okay, that "works for me".  (Sorry. :)
Comment 11 joppe 2007-10-13 08:46:25 PDT
Delete this bug.
I have reproduced the problem and the problem is Saft (http://haoli.dnsalias.com/Saft/index.html).
For some reason, its rules like blocking /ad/ blocked this websites TD-class "padbottom10" too it seems.