Bug 153175 - [GTK] current trunk fails to configure if CMAKE_SHARED_LINKER_FLAGS is unset
Summary: [GTK] current trunk fails to configure if CMAKE_SHARED_LINKER_FLAGS is unset
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-15 19:51 PST by Jeremy Huddleston Sequoia
Modified: 2016-01-17 22:49 PST (History)
2 users (show)

See Also:


Attachments
patch to add missing quotes (1.52 KB, patch)
2016-01-17 15:31 PST, Jeremy Huddleston Sequoia
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Huddleston Sequoia 2016-01-15 19:51:01 PST
With current trunk (git-svn-id: http://svn.webkit.org/repository/webkit/trunk@195161 268f45cc-cd09-0410-ab3c-d52691b4dbfc), cmake fails.  The same command works fine to configure webkit-gtk-2.11.3


export CC='/usr/bin/clang'
export CXX='/usr/bin/clang++'
export OBJC='/usr/bin/clang'
export OBJCXX='/usr/bin/clang++'
export CPATH='/opt/local/include'
export CFLAGS='-pipe -O0 -ftemplate-depth=256'
export CXXFLAGS='-pipe -O0 -ftemplate-depth=256 -stdlib=libc++'
export OBJCFLAGS='-pipe -O0 -ftemplate-depth=256'
export OBJCXXFLAGS='-pipe -O0 -ftemplate-depth=256 -stdlib=libc++'

/opt/local/bin/cmake -DCMAKE_INSTALL_PREFIX=/opt/local -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_COLOR_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_NAME_DIR=/opt/local/lib -DCMAKE_MODULE_PATH=/opt/local/share/cmake/Modules -DCMAKE_FIND_FRAMEWORK=LAST -Wno-dev -DPORT=GTK -DENABLE_X11_TARGET=ON -DENABLE_QUARTZ_TARGET=OFF -DENABLE_INTROSPECTION=OFF -DLLVM_CONFIG_EXE=/opt/local/bin/llvm-config-mp-3.7 -DENABLE_VIDEO=ON -DENABLE_PLUGIN_PROCESS_GTK2=ON -DCMAKE_C_FLAGS_RELEASE="-UNDEBUG" -DCMAKE_CXX_FLAGS_RELEASE="-UNDEBUG" -DCMAKE_OSX_ARCHITECTURES="x86_64" -DCMAKE_OSX_DEPLOYMENT_TARGET="10.10" -DCMAKE_OSX_SYSROOT="/" -DUSE_SYSTEM_MALLOC=ON -DENABLE_MINIBROWSER=ON


Error:

CMake Error at Source/WebKit2/PlatformGTK.cmake:897 (string):
  string sub-command REGEX, mode MATCHALL needs at least 5 arguments total to
  command.
Call Stack (most recent call first):
  Source/cmake/WebKitMacros.cmake:5 (include)
  Source/WebKit2/CMakeLists.txt:767 (WEBKIT_INCLUDE_CONFIG_FILES_IF_EXISTS)

Full output:

-- The C compiler identification is AppleClang 7.2.0.7020025
-- The CXX compiler identification is AppleClang 7.2.0.7020025
-- Check for working C compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang
-- Check for working C compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++
-- Check for working CXX compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
usage:  ar -d [-TLsv] archive file ...
	ar -m [-TLsv] archive file ...
	ar -m [-abiTLsv] position archive file ...
	ar -p [-TLsv] archive [file ...]
	ar -q [-cTLsv] archive file ...
	ar -r [-cuTLsv] archive file ...
	ar -r [-abciuTLsv] position archive file ...
	ar -t [-TLsv] archive [file ...]
	ar -x [-ouTLsv] archive [file ...]
CMake Warning at Source/cmake/OptionsCommon.cmake:81 (message):
  GNU gold linker isn't available, using the default system linker.
Call Stack (most recent call first):
  CMakeLists.txt:115 (include)


-- Found PkgConfig: /opt/local/bin/pkg-config (found version "0.28") 
-- Found Cairo: /opt/local/include/cairo (found suitable version "1.14.6", minimum required is "1.10.2") 
-- Checking for module 'fontconfig'
--   Found fontconfig, version 2.11.1
-- Found Fontconfig: /opt/local/lib/libfontconfig.dylib (Required is at least version "2.8.0") 
-- Checking for module 'freetype2'
--   Found freetype2, version 18.2.12
-- Found Freetype2: /opt/local/include/freetype2/freetype;/opt/local/include/freetype2 (Required is at least version "2.4.2") 
-- Checking for module 'gtk+-3.0'
--   Found gtk+-3.0, version 3.18.6
-- Checking for module 'gtk+-quartz-3.0'
--   Package 'gtk+-quartz-3.0' not found
-- Checking for module 'gtk+-x11-3.0'
--   Found gtk+-x11-3.0, version 3.18.6
-- Checking for module 'gtk+-wayland-3.0'
--   Package 'gtk+-wayland-3.0' not found
-- Found GTK3: /opt/local/include/gtk-3.0;/opt/local/include/at-spi2-atk/2.0;/opt/local/include/at-spi-2.0;/opt/local/include/dbus-1.0;/opt/local/lib/dbus-1.0/include;/opt/local/include/gtk-3.0;/opt/local/include/gio-unix-2.0/;/opt/local/include;/opt/local/include/cairo;/opt/local/include;/opt/local/include/pango-1.0;/opt/local/include/harfbuzz;/opt/local/include;/opt/local/include/pango-1.0;/opt/local/include/atk-1.0;/opt/local/include/cairo;/opt/local/include/pixman-1;/opt/local/include;/opt/local/include/freetype2;/opt/local/include;/opt/local/include/libpng16;/opt/local/include;/opt/local/include/freetype2;/opt/local/include;/opt/local/include/libpng16;/opt/local/include;/opt/local/include/gdk-pixbuf-2.0;/opt/local/include/libpng16;/opt/local/include/glib-2.0;/opt/local/lib/glib-2.0/include;/opt/local/include (Required is at least version "3.6.0") 
-- Checking for module 'gdk-3.0'
--   Found gdk-3.0, version 3.18.6
-- Found GDK3: /opt/local/include/gtk-3.0;/opt/local/include/gio-unix-2.0/;/opt/local/include;/opt/local/include/cairo;/opt/local/include;/opt/local/include/pango-1.0;/opt/local/include/harfbuzz;/opt/local/include;/opt/local/include/pango-1.0;/opt/local/include/gdk-pixbuf-2.0;/opt/local/include/libpng16;/opt/local/include/cairo;/opt/local/include/pixman-1;/opt/local/include;/opt/local/include/freetype2;/opt/local/include;/opt/local/include/libpng16;/opt/local/include;/opt/local/include/freetype2;/opt/local/include;/opt/local/include/libpng16;/opt/local/include;/opt/local/include/glib-2.0;/opt/local/lib/glib-2.0/include;/opt/local/include (Required is at least version "3.6.0") 
-- Checking for module 'harfbuzz>=0.9.7'
--   Found harfbuzz, version 1.1.2
-- Checking for module 'harfbuzz-icu>=0.9.18'
--   Found harfbuzz-icu, version 1.1.2
-- Found HarfBuzz: /opt/local/include/harfbuzz (Required is at least version "0.9.2") 
-- Checking for module 'icu-uc'
--   Found icu-uc, version 55.1
-- Checking for module 'icu-i18n'
--   Found icu-i18n, version 55.1
-- Found ICU header files in /opt/local/include
-- Found ICU libraries: /opt/local/lib/libicuuc.dylib
-- Found JPEG: /opt/local/lib/libjpeg.dylib  
-- Found LibSoup: /opt/local/include/libsoup-2.4 (found suitable version "2.52.2", minimum required is "2.42.0") 
-- Found LibXml2: /opt/local/lib/libxml2.dylib (found suitable version "2.9.2", minimum required is "2.8.0") 
-- Found LibXslt: /opt/local/lib/libxslt.dylib (found suitable version "1.1.28", minimum required is "1.1.7") 
-- Found ZLIB: /opt/local/lib/libz.dylib (found version "1.2.8") 
-- Found PNG: /opt/local/lib/libpng.dylib (found version "1.6.20") 
-- Checking for module 'sqlite3'
--   Found sqlite3, version 3.9.2
-- Found Sqlite: /opt/local/include  
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - found
-- Found Threads: TRUE  
-- Checking for module 'atk'
--   Found atk, version 2.18.0
-- Found ATK: /opt/local/include/atk-1.0 (found version "2.18.0") 
-- Checking for module 'libwebp'
--   Found libwebp, version 0.5.0
-- Found WEBP: webp  
-- Checking for module 'atspi-2'
--   Found atspi-2, version 2.18.3
-- Found ATSPI: /opt/local/include/at-spi-2.0;/opt/local/include/dbus-1.0;/opt/local/lib/dbus-1.0/include;/opt/local/include/glib-2.0;/opt/local/lib/glib-2.0/include;/opt/local/include (Required is at least version "2.5.3") 
-- Checking for module 'egl'
--   Package 'egl' not found
-- Could NOT find EGL (missing:  EGL_INCLUDE_DIRS EGL_LIBRARIES) 
-- Checking for module 'gtk+-unix-print-3.0'
--   Found gtk+-unix-print-3.0, version 3.18.6
-- Found GTK_UNIX_PRINT: /opt/local/include/gtk-3.0/unix-print;/opt/local/include/gtk-3.0;/opt/local/include/at-spi2-atk/2.0;/opt/local/include/at-spi-2.0;/opt/local/include/dbus-1.0;/opt/local/lib/dbus-1.0/include;/opt/local/include/gtk-3.0;/opt/local/include/gio-unix-2.0/;/opt/local/include;/opt/local/include/cairo;/opt/local/include;/opt/local/include/pango-1.0;/opt/local/include/harfbuzz;/opt/local/include;/opt/local/include/pango-1.0;/opt/local/include/atk-1.0;/opt/local/include/cairo;/opt/local/include/pixman-1;/opt/local/include;/opt/local/include/freetype2;/opt/local/include;/opt/local/include/libpng16;/opt/local/include;/opt/local/include/freetype2;/opt/local/include;/opt/local/include/libpng16;/opt/local/include;/opt/local/include/gdk-pixbuf-2.0;/opt/local/include/libpng16;/opt/local/include/glib-2.0;/opt/local/lib/glib-2.0/include;/opt/local/include  
-- Checking for module 'gl'
--   Found gl, version 11.1.0
-- Found OPENGL: /opt/local/include  
-- Looking for include file GL/glx.h
-- Looking for include file GL/glx.h - found
-- Checking for module 'glesv2'
--   Found glesv2, version 11.1.0
-- Found OPENGLES2: /opt/local/include  
-- Found GLIB: /opt/local/include/glib-2.0;/opt/local/lib/glib-2.0/include (found suitable version "2.46.2", minimum required is "2.36") 
-- Checking for module 'libsecret-1'
--   Found libsecret-1, version 0.18.3
-- Found LIBSECRET: /opt/local/include/libsecret-1;/opt/local/include/glib-2.0;/opt/local/lib/glib-2.0/include;/opt/local/include  
-- Found LLVM: 3.7.1 (found suitable version "3.7.1", minimum required is "3.7") 
-- Checking for module 'geoclue-2.0'
--   Found geoclue-2.0, version 2.4.1
-- Found GEOCLUE2: TRUE  
-- Checking for module 'gtk+-2.0'
--   Found gtk+-2.0, version 2.24.29
-- Found GTK2: /opt/local/include/gtk-2.0;/opt/local/lib/gtk-2.0/include;/opt/local/include/pango-1.0;/opt/local/include/gio-unix-2.0/;/opt/local/include;/opt/local/include/cairo;/opt/local/include/atk-1.0;/opt/local/include/cairo;/opt/local/include/pixman-1;/opt/local/include;/opt/local/include/gdk-pixbuf-2.0;/opt/local/include/libpng16;/opt/local/include/pango-1.0;/opt/local/include/harfbuzz;/opt/local/include;/opt/local/include/pango-1.0;/opt/local/include/glib-2.0;/opt/local/lib/glib-2.0/include;/opt/local/include;/opt/local/include/freetype2;/opt/local/include;/opt/local/include/libpng16;/opt/local/include;/opt/local/include/freetype2;/opt/local/include;/opt/local/include/libpng16 (Required is at least version "2.24.10") 
-- Checking for module 'gdk-2.0'
--   Found gdk-2.0, version 2.24.29
-- Found GDK2: /opt/local/include/gtk-2.0;/opt/local/lib/gtk-2.0/include;/opt/local/include/pango-1.0;/opt/local/include/harfbuzz;/opt/local/include;/opt/local/include/pango-1.0;/opt/local/include/gio-unix-2.0/;/opt/local/include;/opt/local/include/gdk-pixbuf-2.0;/opt/local/include/libpng16;/opt/local/include/cairo;/opt/local/include/glib-2.0;/opt/local/lib/glib-2.0/include;/opt/local/include;/opt/local/include/pixman-1;/opt/local/include;/opt/local/include/freetype2;/opt/local/include;/opt/local/include/libpng16;/opt/local/include;/opt/local/include/freetype2;/opt/local/include;/opt/local/include/libpng16;/opt/local/include (Required is at least version "2.24.10") 
-- Checking for module 'enchant'
--   Found enchant, version 1.6.0
-- Checking for module 'gstreamer-1.0 >= 1.0.3'
--   Found gstreamer-1.0 , version 1.6.2
-- Checking for module 'gstreamer-base-1.0 >= 1.0.3'
--   Found gstreamer-base-1.0 , version 1.6.2
-- Checking for module 'gstreamer-app-1.0 >= 1.0.3'
--   Found gstreamer-app-1.0 , version 1.6.2
-- Checking for module 'gstreamer-audio-1.0 >= 1.0.3'
--   Found gstreamer-audio-1.0 , version 1.6.2
-- Checking for module 'gstreamer-fft-1.0 >= 1.0.3'
--   Found gstreamer-fft-1.0 , version 1.6.2
-- Checking for module 'gstreamer-gl-1.0>=1.5.0'
--   Found gstreamer-gl-1.0, version 1.6.2
-- Checking for module 'gstreamer-mpegts-1.0>=1.4.0'
--   Found gstreamer-mpegts-1.0, version 1.6.2
-- Checking for module 'gstreamer-pbutils-1.0 >= 1.0.3'
--   Found gstreamer-pbutils-1.0 , version 1.6.2
-- Checking for module 'gstreamer-tag-1.0 >= 1.0.3'
--   Found gstreamer-tag-1.0 , version 1.6.2
-- Checking for module 'gstreamer-video-1.0 >= 1.0.3'
--   Found gstreamer-video-1.0 , version 1.6.2
-- Found GStreamer: GSTREAMER_INCLUDE_DIRS;GSTREAMER_LIBRARIES;GSTREAMER_VERSION;GSTREAMER_BASE_INCLUDE_DIRS;GSTREAMER_BASE_LIBRARIES;GSTREAMER_APP_INCLUDE_DIRS;GSTREAMER_APP_LIBRARIES;GSTREAMER_PBUTILS_INCLUDE_DIRS;GSTREAMER_PBUTILS_LIBRARIES;GSTREAMER_VIDEO_INCLUDE_DIRS;GSTREAMER_VIDEO_LIBRARIES;GSTREAMER_MPEGTS_INCLUDE_DIRS;GSTREAMER_MPEGTS_LIBRARIES;GSTREAMER_TAG_INCLUDE_DIRS;GSTREAMER_TAG_LIBRARIES;GSTREAMER_GL_INCLUDE_DIRS;GSTREAMER_GL_LIBRARIES;GSTREAMER_AUDIO_INCLUDE_DIRS;GSTREAMER_AUDIO_LIBRARIES;GSTREAMER_FFT_INCLUDE_DIRS;GSTREAMER_FFT_LIBRARIES (Required is at least version "1.0.3") 
-- Looking for XOpenDisplay in /opt/local/lib/libX11.dylib;/opt/local/lib/libXext.dylib
-- Looking for XOpenDisplay in /opt/local/lib/libX11.dylib;/opt/local/lib/libXext.dylib - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /opt/local/lib/libX11.dylib
-- Found LibNotify: /opt/local/include;/opt/local/include/gdk-pixbuf-2.0;/opt/local/include/libpng16;/opt/local/include/glib-2.0;/opt/local/lib/glib-2.0/include;/opt/local/include (found version "0.7.6") 
-- Found HYPHEN: /opt/local/include  
-- Using platform-specific CMakeLists: /Volumes/Home/jeremy/src/WebKit/Source/bmalloc/PlatformGTK.cmake
-- Found BISON: /opt/local/bin/bison (found suitable version "3.0.4", minimum required is "2.1") 
-- Found Gperf: /opt/local/bin/gperf (Required is at least version "3.0.1") 
-- Found Perl: /opt/local/bin/perl (found suitable version "5.22.1", minimum required is "5.10.0") 
-- Found PythonInterp: /opt/local/bin/python2.7 (found suitable version "2.7.11", minimum required is "2.7.0") 
-- Found Ruby: /opt/local/bin/ruby (found suitable version "2.2.0", minimum required is "1.9") 
usage:  ar -d [-TLsv] archive file ...
	ar -m [-TLsv] archive file ...
	ar -m [-abiTLsv] position archive file ...
	ar -p [-TLsv] archive [file ...]
	ar -q [-cTLsv] archive file ...
	ar -r [-cuTLsv] archive file ...
	ar -r [-abciuTLsv] position archive file ...
	ar -t [-TLsv] archive [file ...]
	ar -x [-ouTLsv] archive [file ...]
-- Checking for module 'gtk+-quartz-3.0'
--   Package 'gtk+-quartz-3.0' not found
-- Checking for module 'gtk+-wayland-3.0'
--   Package 'gtk+-wayland-3.0' not found
-- Found HarfBuzz: /opt/local/include/harfbuzz (Required is at least version "0.9.2") 
-- Found ICU header files in /opt/local/include
-- Found ICU libraries: /opt/local/lib/libicuuc.dylib
-- Checking for module 'egl'
--   Package 'egl' not found
-- Could NOT find EGL (missing:  EGL_INCLUDE_DIRS EGL_LIBRARIES) 
-- Found GLIB: /opt/local/include/glib-2.0;/opt/local/lib/glib-2.0/include (found suitable version "2.46.2", minimum required is "2.36") 
-- Using platform-specific CMakeLists: /Volumes/Home/jeremy/src/WebKit/Source/WTF/wtf/PlatformGTK.cmake
usage:  ar -d [-TLsv] archive file ...
	ar -m [-TLsv] archive file ...
	ar -m [-abiTLsv] position archive file ...
	ar -p [-TLsv] archive [file ...]
	ar -q [-cTLsv] archive file ...
	ar -r [-cuTLsv] archive file ...
	ar -r [-abciuTLsv] position archive file ...
	ar -t [-TLsv] archive [file ...]
	ar -x [-ouTLsv] archive [file ...]
-- Checking for module 'gtk+-quartz-3.0'
--   Package 'gtk+-quartz-3.0' not found
-- Checking for module 'gtk+-wayland-3.0'
--   Package 'gtk+-wayland-3.0' not found
-- Found ICU header files in /opt/local/include
-- Found ICU libraries: /opt/local/lib/libicuuc.dylib
-- Checking for module 'egl'
--   Package 'egl' not found
-- Could NOT find EGL (missing:  EGL_INCLUDE_DIRS EGL_LIBRARIES) 
-- Using platform-specific CMakeLists: /Volumes/Home/jeremy/src/WebKit/Source/JavaScriptCore/PlatformGTK.cmake
-- Using platform-specific CMakeLists: /Volumes/Home/jeremy/src/WebKit/Source/JavaScriptCore/shell/PlatformGTK.cmake
usage:  ar -d [-TLsv] archive file ...
	ar -m [-TLsv] archive file ...
	ar -m [-abiTLsv] position archive file ...
	ar -p [-TLsv] archive [file ...]
	ar -q [-cTLsv] archive file ...
	ar -r [-cuTLsv] archive file ...
	ar -r [-abciuTLsv] position archive file ...
	ar -t [-TLsv] archive [file ...]
	ar -x [-ouTLsv] archive [file ...]
-- Checking for module 'gtk+-quartz-3.0'
--   Package 'gtk+-quartz-3.0' not found
-- Checking for module 'gtk+-wayland-3.0'
--   Package 'gtk+-wayland-3.0' not found
-- Found ICU header files in /opt/local/include
-- Found ICU libraries: /opt/local/lib/libicuuc.dylib
-- Checking for module 'egl'
--   Package 'egl' not found
-- Could NOT find EGL (missing:  EGL_INCLUDE_DIRS EGL_LIBRARIES) 
-- Using platform-specific CMakeLists: /Volumes/Home/jeremy/src/WebKit/Source/WebCore/PlatformGTK.cmake
-- Using platform-specific CMakeLists: /Volumes/Home/jeremy/src/WebKit/Source/WebKit2/PlatformGTK.cmake
CMake Error at Source/WebKit2/PlatformGTK.cmake:897 (string):
  string sub-command REGEX, mode MATCHALL needs at least 5 arguments total to
  command.
Call Stack (most recent call first):
  Source/cmake/WebKitMacros.cmake:5 (include)
  Source/WebKit2/CMakeLists.txt:767 (WEBKIT_INCLUDE_CONFIG_FILES_IF_EXISTS)


-- Using platform-specific CMakeLists: /Volumes/Home/jeremy/src/WebKit/Source/PlatformGTK.cmake
-- Found Gettext: /opt/local/bin/msgmerge (found version "0.19.7") 
-- Enabled features:
--  ENABLE_ACCELERATED_2D_CANVAS ............ OFF
--  ENABLE_CREDENTIAL_STORAGE                 ON
--  ENABLE_DRAG_SUPPORT ..................... ON
--  ENABLE_FTL_JIT                            ON
--  ENABLE_GEOLOCATION ...................... ON
--  ENABLE_GLES2                              OFF
--  ENABLE_GTKDOC ........................... OFF
--  ENABLE_ICONDATABASE                       ON
--  ENABLE_INTROSPECTION .................... OFF
--  ENABLE_JIT                                ON
--  ENABLE_MEMORY_SAMPLER ................... OFF
--  ENABLE_MINIBROWSER                        ON
--  ENABLE_OPENGL ........................... ON
--  ENABLE_PLUGIN_PROCESS_GTK2                ON
--  ENABLE_QUARTZ_TARGET .................... OFF
--  ENABLE_SPELLCHECK                         ON
--  ENABLE_TOUCH_EVENTS ..................... ON
--  ENABLE_VIDEO                              ON
--  ENABLE_WAYLAND_TARGET ................... OFF
--  ENABLE_WEB_AUDIO                          ON
--  ENABLE_X11_TARGET ....................... ON
--  USE_LIBHYPHEN                             ON
--  USE_LIBNOTIFY ........................... ON
--  USE_SYSTEM_MALLOC                         ON
-- Configuring incomplete, errors occurred!
See also "/Volumes/Home/jeremy/src/WebKit/build/CMakeFiles/CMakeOutput.log".
Comment 1 Jeremy Huddleston Sequoia 2016-01-16 20:52:55 PST
worksforme now.
Comment 2 Jeremy Huddleston Sequoia 2016-01-17 15:28:27 PST
And then stopped working.  I see what the issue is.
Comment 3 Jeremy Huddleston Sequoia 2016-01-17 15:30:17 PST
CMAKE_SHARED_LINKER_FLAGS
Comment 4 Jeremy Huddleston Sequoia 2016-01-17 15:31:44 PST
Created attachment 269202 [details]
patch to add missing quotes
Comment 5 Michael Catanzaro 2016-01-17 19:51:33 PST
Comment on attachment 269202 [details]
patch to add missing quotes

Thanks. Don't forget to request cq? if you want commit-queue (you do). :)
Comment 6 WebKit Commit Bot 2016-01-17 20:41:34 PST
Comment on attachment 269202 [details]
patch to add missing quotes

Clearing flags on attachment: 269202

Committed r195186: <http://trac.webkit.org/changeset/195186>
Comment 7 WebKit Commit Bot 2016-01-17 20:41:37 PST
All reviewed patches have been landed.  Closing bug.