Bug 153122 - [GTK] List box selections stopped working again with GTK+ from current git master
Summary: [GTK] List box selections stopped working again with GTK+ from current git ma...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Local Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2016-01-15 04:28 PST by Carlos Garcia Campos
Modified: 2016-01-16 01:44 PST (History)
5 users (show)

See Also:


Attachments
Patch (2.61 KB, patch)
2016-01-15 04:31 PST, Carlos Garcia Campos
mcatanzaro: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2016-01-15 04:28:54 PST
The problem is that the ListBox selection implementation is wrong. We are using a similar implementation to GtkEntry, but GtkTreeView doesn't have a child CSS node for selections.
Comment 1 Carlos Garcia Campos 2016-01-15 04:31:55 PST
Created attachment 269044 [details]
Patch
Comment 2 Carlos Garcia Campos 2016-01-16 01:44:38 PST
Committed r195167: <http://trac.webkit.org/changeset/195167>