Bug 152722 - Crash and assertion when scrolling webkit.org page before it finishes loading
Summary: Crash and assertion when scrolling webkit.org page before it finishes loading
Status: RESOLVED DUPLICATE of bug 118269
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-04 17:46 PST by Said Abou-Hallawa
Modified: 2020-02-06 13:17 PST (History)
3 users (show)

See Also:


Attachments
webkit.org incorrect display (150.87 KB, image/png)
2016-01-04 17:46 PST, Said Abou-Hallawa
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Said Abou-Hallawa 2016-01-04 17:46:05 PST
Created attachment 268253 [details]
webkit.org incorrect display

Launch MiniBrowser WK2 window in Xcode and quickly scroll the page down. The output window will have the following dump. Also the page will not have the sticky navigation bar with the webkit title and logo; see the attached picture.

ASSERTION FAILED: m_repaintRect == renderer().clippedOverflowRectForRepaint(renderer().containerForRepaint())
/Volumes/Data/WebKit/OpenSource/Source/WebCore/rendering/RenderLayer.cpp(861) : void WebCore::RenderLayer::updateLayerPositionsAfterScroll(WebCore::RenderGeometryMap *, UpdateLayerPositionsAfterScrollFlags)
1   0x115a49dc0 WTFCrash
2   0x1193b1084 WebCore::RenderLayer::updateLayerPositionsAfterScroll(WebCore::RenderGeometryMap*, unsigned int)
3   0x1193b116e WebCore::RenderLayer::updateLayerPositionsAfterScroll(WebCore::RenderGeometryMap*, unsigned int)
4   0x1193b116e WebCore::RenderLayer::updateLayerPositionsAfterScroll(WebCore::RenderGeometryMap*, unsigned int)
5   0x1193b116e WebCore::RenderLayer::updateLayerPositionsAfterScroll(WebCore::RenderGeometryMap*, unsigned int)
6   0x1193b116e WebCore::RenderLayer::updateLayerPositionsAfterScroll(WebCore::RenderGeometryMap*, unsigned int)
7   0x1193b0dce WebCore::RenderLayer::updateLayerPositionsAfterDocumentScroll()
8   0x118232348 WebCore::FrameView::updateLayerPositionsAfterScrolling()
9   0x1196f9e2c WebCore::ScrollView::completeUpdatesAfterScrollTo(WebCore::IntSize const&)
10  0x1196fa2bc WebCore::ScrollView::scrollTo(WebCore::IntPoint const&)
11  0x118235e14 WebCore::FrameView::scrollTo(WebCore::IntPoint const&)
12  0x1196f94cc WebCore::ScrollView::setScrollOffset(WebCore::IntPoint const&)
13  0x1196f954f non-virtual thunk to WebCore::ScrollView::setScrollOffset(WebCore::IntPoint const&)
14  0x1196a44ff WebCore::ScrollableArea::scrollPositionChanged(WebCore::IntPoint const&)
15  0x1196a444f WebCore::ScrollableArea::notifyScrollPositionChanged(WebCore::IntPoint const&)
16  0x117940003 WebCore::AsyncScrollingCoordinator::updateScrollPositionAfterAsyncScroll(unsigned long long, WebCore::FloatPoint const&, bool, WebCore::SetOrSyncScrollingLayerPosition)
17  0x11793eee1 WebCore::AsyncScrollingCoordinator::updateScrollPositionAfterAsyncScrollTimerFired()
18  0x1179450c8 void std::__1::__invoke_void_return_wrapper<void>::__call<std::__1::__bind<void (WebCore::AsyncScrollingCoordinator::*&)(), WebCore::AsyncScrollingCoordinator*>&>(std::__1::__bind<void (WebCore::AsyncScrollingCoordinator::*&)(), WebCore::AsyncScrollingCoordinator*>&&&)
19  0x117944f9c std::__1::__function::__func<std::__1::__bind<void (WebCore::AsyncScrollingCoordinator::*&)(), WebCore::AsyncScrollingCoordinator*>, std::__1::allocator<std::__1::__bind<void (WebCore::AsyncScrollingCoordinator::*&)(), WebCore::AsyncScrollingCoordinator*> >, void ()>::operator()()
20  0x1178714fa std::__1::function<void ()>::operator()() const
21  0x11787141c WebCore::Timer::fired()
22  0x119b2f41a WebCore::ThreadTimers::sharedTimerFiredInternal()
23  0x119b30661 WebCore::ThreadTimers::setSharedTimer(WebCore::SharedTimer*)::$_0::operator()() const
24  0x119b3062d void std::__1::__invoke_void_return_wrapper<void>::__call<WebCore::ThreadTimers::setSharedTimer(WebCore::SharedTimer*)::$_0&>(WebCore::ThreadTimers::setSharedTimer(WebCore::SharedTimer*)::$_0&&&)
25  0x119b305cc std::__1::__function::__func<WebCore::ThreadTimers::setSharedTimer(WebCore::SharedTimer*)::$_0, std::__1::allocator<WebCore::ThreadTimers::setSharedTimer(WebCore::SharedTimer*)::$_0>, void ()>::operator()()
26  0x1178714fa std::__1::function<void ()>::operator()() const
27  0x118efb9f0 WebCore::MainThreadSharedTimer::fired()
28  0x118efbed9 WebCore::timerFired(__CFRunLoopTimer*, void*)
29  0x7fff867f79f4 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__
30  0x7fff867f7683 __CFRunLoopDoTimer
31  0x7fff867f71da __CFRunLoopDoTimers
2016-01-04 17:35:08.368 MiniBrowser[98410:252093] WebContent process crashed; reloading
Jan  4 17:35:09  MiniBrowser[98410] <Error>: CGImageCreateWithImageProvider: invalid image size: 0 x 0.
Jan  4 17:35:13  MiniBrowser[98410] <Error>: CGImageCreateWithImageProvider: invalid image size: 0 x 0.
Jan  4 17:35:17  MiniBrowser[98410] <Error>: CGImageCreateWithImageProvider: invalid image size: 0 x 0.
Comment 1 Michael Catanzaro 2020-02-06 13:17:39 PST

*** This bug has been marked as a duplicate of bug 118269 ***