RESOLVED FIXED 152450
BytecodeGenerator::pushLexicalScopeInternal and pushLexicalScope should use enums instead of bools
https://bugs.webkit.org/show_bug.cgi?id=152450
Summary BytecodeGenerator::pushLexicalScopeInternal and pushLexicalScope should use e...
Saam Barati
Reported 2015-12-18 15:53:57 PST
This will make the call sites easier to read.
Attachments
patch (12.43 KB, patch)
2015-12-18 16:08 PST, Saam Barati
no flags
patch (12.66 KB, patch)
2015-12-18 16:10 PST, Saam Barati
ggaren: review+
patch (12.74 KB, patch)
2015-12-18 16:11 PST, Saam Barati
joepeck: review+
Saam Barati
Comment 1 2015-12-18 16:08:15 PST
Saam Barati
Comment 2 2015-12-18 16:10:19 PST
Created attachment 267657 [details] patch hopefully this builds.
Geoffrey Garen
Comment 3 2015-12-18 16:11:00 PST
r=me > Source/JavaScriptCore/bytecompiler/BytecodeGenerator.h:707 > + enum class TDZCheckOptimization { CanOptimize, CanNotOptimize }; Technically, cannot is one word. You could do Optimize / DoNotOptimize.
Saam Barati
Comment 4 2015-12-18 16:11:46 PST
Created attachment 267658 [details] patch nope, it doesn't. Maybe this time?
Saam Barati
Comment 5 2015-12-18 16:12:39 PST
(In reply to comment #3) > r=me > > > Source/JavaScriptCore/bytecompiler/BytecodeGenerator.h:707 > > + enum class TDZCheckOptimization { CanOptimize, CanNotOptimize }; > > Technically, cannot is one word. > > You could do Optimize / DoNotOptimize. I'll do that.
Joseph Pecoraro
Comment 6 2015-12-18 16:16:30 PST
Comment on attachment 267658 [details] patch r=me
Saam Barati
Comment 7 2015-12-18 16:20:30 PST
Note You need to log in before you can comment on or make changes to this bug.