Bug 15243 - Hang while connection:willCacheResponse: delegate called on secondary thread
Summary: Hang while connection:willCacheResponse: delegate called on secondary thread
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Major
Assignee: Nobody
URL:
Keywords: InRadar
: 15304 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-09-19 22:25 PDT by Jim Oase
Modified: 2007-10-18 09:27 PDT (History)
4 users (show)

See Also:


Attachments
Pictures of the screens... nothing seemed to work as expected (232.54 KB, image/jpeg)
2007-09-29 07:44 PDT, Jim Oase
no flags Details
Terminal output (20.42 KB, text/plain)
2007-09-29 10:21 PDT, Jim Oase
no flags Details
Terminal output for build 25809 (20.24 KB, text/plain)
2007-09-29 23:19 PDT, Jim Oase
no flags Details
accessing Apple.com (289.21 KB, image/jpeg)
2007-09-29 23:20 PDT, Jim Oase
no flags Details
Latest build 25812 still stalls (20.12 KB, text/plain)
2007-09-30 19:20 PDT, Jim Oase
no flags Details
Build 25915 still does not work with Apple Refurb store (21.36 KB, text/plain)
2007-10-02 11:56 PDT, Jim Oase
no flags Details
Screen shot of build 25915 failure (436.09 KB, image/jpeg)
2007-10-02 11:57 PDT, Jim Oase
no flags Details
Sample of stalling on Consumer report (3.34 KB, text/plain)
2007-10-18 06:53 PDT, Jim Oase
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Oase 2007-09-19 22:25:18 PDT
The last two builds have stalled frequently.  

Digg.com several times

Recently   http://www.dunntire.com/Learning_Center/Tire_Speed_Ratings
Comment 1 David Kilzer (:ddkilzer) 2007-09-20 04:27:59 PDT
Jim, do you get a "spinning beach ball" when the sites stall?

If so, could you run this command (from the Terminal), then attach the file it creates to this bug?

$ sample Safari 10 10

Comment 2 Jim Oase 2007-09-20 19:16:47 PDT
I did not get the beach ball.  Instead I got the spin wheel on the tab.  When I looked at activity, to see what activity was not loading, there was nothing there about the site I was trying to access.  Since then I upgraded twice and the stall seems to have gone away.

Jim
Comment 3 David Kilzer (:ddkilzer) 2007-09-20 20:08:20 PDT
Closing as RESOLVED/WORKSFORME.  If you see this again, Jim, please reopen this bug, run the "sample" command, and attach it to this bug.  Thanks!
Comment 4 Jim Oase 2007-09-29 07:44:38 PDT
Created attachment 16449 [details]
Pictures of the screens... nothing seemed to work as expected

I could not find  the tmp/safari file.  I was attempting to access the Apple site.  The first stall occurred when accessing the for resale site and the next time the main Apple site.  Both times WebKit stopped responding with beach ball in full bloom.

I copied and pasted the Terminal line.... initially it didn't work... because of the additional $

I have since run Oxyn utility with the idea of clearing all chaches...  I will let you know how that works

JIm
Comment 5 David Kilzer (:ddkilzer) 2007-09-29 09:49:02 PDT
(In reply to comment #4)
> I could not find  the tmp/safari file.  I was attempting to access the Apple
> site.  The first stall occurred when accessing the for resale site and the next
> time the main Apple site.  Both times WebKit stopped responding with beach ball
> in full bloom.

The easiest way to get to /tmp is:

1. Double-click on "Macintosh HD" (or whatever your hard drive is named) in the Finder.
2. Hit Cmd-Shift-G.
3. Type "/tmp" without the double quotes.
4. Click the "Go" button.

> I copied and pasted the Terminal line.... initially it didn't work... because
> of the additional $

Sorry...the $ was there to represent the $ that appears after the prompt on the terminal.

Comment 6 Jim Oase 2007-09-29 10:21:26 PDT
Created attachment 16456 [details]
Terminal output

The stall came as soon as I tried to access the Apple store special savings page.  I am looking for a MacBook for my daughter to use while getting her nursing degree.

Jim
Comment 7 David Kilzer (:ddkilzer) 2007-09-29 11:21:45 PDT
(In reply to comment #6)
> Created an attachment (id=16456) [edit]
> Terminal output

This appears to be related to Bug 15009 (fixed in r25777) based on the output of sample(1) in Attachment 16456 [details], but it appears that this may not have completely fixed the issue.

Jim, which WebKit nightly (or Safari version) were you using when you saw this error?

Comment 8 David Kilzer (:ddkilzer) 2007-09-29 12:47:57 PDT
<rdar://problem/5513807>
Comment 9 Jim Oase 2007-09-29 14:03:24 PDT
Here is the Webkit version
http://nightly.webkit.org/start/?current-revision=25801

This problem appeared on an earlier version and is really bad with this particular version.

Jim
Comment 10 Jim Oase 2007-09-29 23:19:10 PDT
Created attachment 16464 [details]
Terminal output for build 25809

This problem continues to exist when ever I try to access Apple.com ... store... special deals

Sometimes it fail on accessing Apple.com or the next or for sure by the specail deals

Jim
Comment 11 Jim Oase 2007-09-29 23:20:19 PDT
Created attachment 16465 [details]
accessing Apple.com

I hope this is useful information

Jim
Comment 12 David Kilzer (:ddkilzer) 2007-09-30 08:41:09 PDT
*** Bug 15304 has been marked as a duplicate of this bug. ***
Comment 13 David Kilzer (:ddkilzer) 2007-09-30 08:42:00 PDT
Confirmed via duplicate Bug 15304.

Comment 14 David Kilzer (:ddkilzer) 2007-09-30 08:42:37 PDT
(In reply to comment #8)
> <rdar://problem/5513807>

See also <rdar://problem/5511842>

Comment 15 David Kilzer (:ddkilzer) 2007-09-30 09:04:19 PDT
For those that can reproduce this bug easily (Patricia, Jim, Ken), does using a WebKit nightly build BEFORE r25777 fix the issue?

Comment 16 Jim Oase 2007-09-30 09:19:06 PDT
This build does not have a stall..... works fine      WebKit-SVN-r25773.dmg

Jim
Comment 17 Patricia Warwick 2007-09-30 10:45:44 PDT
I too downloaded r25773 and it does not stall on http://store.apple.com/1-800-MY-APPLE/WebObjects/canadastore/
Comment 18 Timothy Hatcher 2007-09-30 17:12:10 PDT
This is happing because of the synchronous XMLHTTPRequest and the performSelectorOnMainThread:withObject:waitUntilDone: I added is causing a deadlock because the runloop for the synchronous connection only runs for some modes. I think a fix would be to use performSelectorOnMainThread:withObject:waitUntilDone:modes:, and pass an array that has the mode that [NSSynchronousURLConnectionDelegate run:] uses in CFRunLoopRunSpecific.

Comment 19 Jim Oase 2007-09-30 19:20:23 PDT
Created attachment 16478 [details]
Latest build 25812 still stalls

I thought you had it until I got looking up refurbed MacBooks

Jim
Comment 20 Patricia Warwick 2007-10-01 10:57:16 PDT
The problem is worse with r25814. I have a bunch of links that I normally open in tabs (from a bookmark) but now it freezes (with spinning ball.)
Comment 21 java designer 2007-10-01 15:48:55 PDT
(In reply to comment #20)
> The problem is worse with r25814. I have a bunch of links that I normally open
> in tabs (from a bookmark) but now it freezes (with spinning ball.)
> 

I too am seeing exactly the same issue with webkit hanging 
at the apple.com/store site and 25814 does NOT fix this
problem (its as bad if not worse).

--j
javadesigner@yahoo.com
Comment 22 Jim Oase 2007-10-02 11:56:00 PDT
Created attachment 16505 [details]
Build 25915 still does not work with Apple Refurb store

The first three levels of Apple.com heading toward the refurb Mac specials all worked great.
Comment 23 Jim Oase 2007-10-02 11:57:22 PDT
Created attachment 16506 [details]
Screen shot of build 25915 failure
Comment 24 David Kilzer (:ddkilzer) 2007-10-02 21:07:36 PDT
Fixed by Tristan in r25940.

http://trac.webkit.org/projects/webkit/changeset/25940

Any nightly build on or after r25940 should no longer hang!  Please open a new bug if you see this behavior again.  Thanks!

Comment 25 Jim Oase 2007-10-02 22:25:29 PDT
Thank you.......

I believe you have lightning in a bottle with this lastest fix.....  

Nice job who ever did it.

Jim
Comment 26 Jim Oase 2007-10-18 06:53:43 PDT
Created attachment 16721 [details]
Sample of stalling on Consumer report

http://www.consumerreports.org/cro/index.htm

This is an  example of a site that recently stalled for over 30 seconds before loading

Jim
Comment 27 David Kilzer (:ddkilzer) 2007-10-18 09:27:28 PDT
(In reply to comment #26)
> Created an attachment (id=16721) [edit]
> Sample of stalling on Consumer report
> 
> http://www.consumerreports.org/cro/index.htm
> 
> This is an  example of a site that recently stalled for over 30 seconds before
> loading

Thanks, Jim!  This is actually a different bug.  Could you open a new bug for this issue?  The version of the nightly being used (rNNNNN) to reproduce the issue is extremely helpful as well.