Bug 152173 - REGRESSION (r191613): Web Inspector: Can't type spaces when editing DOM nodes
Summary: REGRESSION (r191613): Web Inspector: Can't type spaces when editing DOM nodes
Status: VERIFIED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: Macintosh OS X 10.11
: P2 Normal
Assignee: Joseph Pecoraro
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2015-12-11 06:50 PST by Michael Bailey
Modified: 2015-12-12 20:01 PST (History)
8 users (show)

See Also:


Attachments
[PATCH] Proposed Fix (2.01 KB, patch)
2015-12-12 00:06 PST, Joseph Pecoraro
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Bailey 2015-12-11 06:50:37 PST
At some point recently, I stopped being able to type spaces when editing DOM nodes in the Web Inspector's "Elements" tab. Typing any other character works, and I can work around the issue by copying and pasting spaces.

STR:
1. Open the Web Inspector to the "Elements" tab.
2. Double click any element or text node to edit its contents.
3. Press the space bar.

Expected:
Spaces should be typed into the selected field.

Actual:
Nothing happens.

This works as expected in Safari 9.0.2 (11601.3.9), but is broken in WebKit r193949. I think it broke within the last couple weeks.
Comment 1 Radar WebKit Bug Importer 2015-12-11 06:51:04 PST
<rdar://problem/23857868>
Comment 2 Nikita Vasilyev 2015-12-11 22:01:15 PST
Bisecting tells me that the regression was introduced by:
http://trac.webkit.org/changeset/191613
Comment 3 Joseph Pecoraro 2015-12-11 23:00:12 PST
(In reply to comment #2)
> Bisecting tells me that the regression was introduced by:
> http://trac.webkit.org/changeset/191613

Really? Hah. I wonder if the keyboard shortcuts should start out disabled, since they are only meant to be enabled / disabled when the TabContentView is shown, but they don't look disabled when created.
Comment 4 Joseph Pecoraro 2015-12-12 00:06:31 PST
Created attachment 267228 [details]
[PATCH] Proposed Fix
Comment 5 WebKit Commit Bot 2015-12-12 09:37:58 PST
Comment on attachment 267228 [details]
[PATCH] Proposed Fix

Clearing flags on attachment: 267228

Committed r194009: <http://trac.webkit.org/changeset/194009>
Comment 6 WebKit Commit Bot 2015-12-12 09:38:02 PST
All reviewed patches have been landed.  Closing bug.
Comment 7 Michael Bailey 2015-12-12 20:01:31 PST
Looks good in the r194012 nightly. Thanks!