Bug 15209 - Sometimes removing an iframe from the DOM does not remove its frame from the page
Summary: Sometimes removing an iframe from the DOM does not remove its frame from the ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Frames (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 14503 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-09-13 15:49 PDT by Geoffrey Garen
Modified: 2007-09-14 10:22 PDT (History)
1 user (show)

See Also:


Attachments
Reduction (699 bytes, text/html)
2007-09-13 15:51 PDT, Geoffrey Garen
no flags Details
Patch (10.92 KB, patch)
2007-09-13 20:55 PDT, Geoffrey Garen
no flags Details | Formatted Diff | Diff
Patch 2 (17.10 KB, patch)
2007-09-13 20:59 PDT, Geoffrey Garen
ggaren: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey Garen 2007-09-13 15:49:51 PDT
Testcase coming.
Comment 1 Geoffrey Garen 2007-09-13 15:51:01 PDT
Created attachment 16284 [details]
Reduction
Comment 2 Geoffrey Garen 2007-09-13 15:51:35 PDT
Noticed this while investigating bug 14503. It seems to be related.
Comment 3 Geoffrey Garen 2007-09-13 15:55:58 PDT
Happens on Windows and Mac.
Comment 4 Geoffrey Garen 2007-09-13 20:55:01 PDT
Created attachment 16287 [details]
Patch

I think this patch is a key to fixing bug 14503.
Comment 5 Geoffrey Garen 2007-09-13 20:59:15 PDT
Created attachment 16288 [details]
Patch 2

Updated patch with correct layout test results.
Comment 6 Geoffrey Garen 2007-09-13 23:27:44 PDT
Comment on attachment 16288 [details]
Patch 2

Adam Roben reviewed this.
Comment 7 Geoffrey Garen 2007-09-13 23:36:42 PDT
*** Bug 14503 has been marked as a duplicate of this bug. ***
Comment 8 Geoffrey Garen 2007-09-14 10:22:08 PDT
Committed revision 25563.