WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
152073
[TexMap] Clean up BitmapTexturePool
https://bugs.webkit.org/show_bug.cgi?id=152073
Summary
[TexMap] Clean up BitmapTexturePool
Zan Dobersek
Reported
2015-12-09 10:08:47 PST
[TexMap] Clean up BitmapTexturePool
Attachments
Patch
(9.21 KB, patch)
2015-12-09 10:18 PST
,
Zan Dobersek
no flags
Details
Formatted Diff
Diff
Patch for landing
(9.27 KB, patch)
2015-12-10 00:47 PST
,
Zan Dobersek
no flags
Details
Formatted Diff
Diff
Show Obsolete
(1)
View All
Add attachment
proposed patch, testcase, etc.
Zan Dobersek
Comment 1
2015-12-09 10:18:39 PST
Created
attachment 267019
[details]
Patch
WebKit Commit Bot
Comment 2
2015-12-09 10:20:37 PST
Attachment 267019
[details]
did not pass style-queue: ERROR: Source/WebCore/platform/graphics/texmap/BitmapTexturePool.cpp:50: More than one command on the same line [whitespace/newline] [4] ERROR: Source/WebCore/platform/graphics/texmap/BitmapTexturePool.cpp:77: More than one command on the same line [whitespace/newline] [4] Total errors found: 2 in 4 files If any of these errors are false positives, please file a bug against check-webkit-style.
Daniel Bates
Comment 3
2015-12-09 12:37:13 PST
Comment on
attachment 267019
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=267019&action=review
> Source/WebCore/platform/graphics/texmap/BitmapTexturePool.h:63 > + void markUsed() { m_timeLastUsed = monotonicallyIncreasingTime(); }
This is OK as-is. Maybe using the present tense in naming this method would be better: markIsInUse()?
> Source/WebCore/platform/graphics/texmap/BitmapTexturePool.h:66 > + double m_timeLastUsed;
This is minor. We tend to prefer names where the adjective/verb comes before the noun. Maybe a better name for this instance variable would be m_lastUsedTime?
Zan Dobersek
Comment 4
2015-12-10 00:44:59 PST
(In reply to
comment #3
)
> Comment on
attachment 267019
[details]
> Patch > > View in context: >
https://bugs.webkit.org/attachment.cgi?id=267019&action=review
> > > Source/WebCore/platform/graphics/texmap/BitmapTexturePool.h:63 > > + void markUsed() { m_timeLastUsed = monotonicallyIncreasingTime(); } > > This is OK as-is. Maybe using the present tense in naming this method would > be better: markIsInUse()? > > > Source/WebCore/platform/graphics/texmap/BitmapTexturePool.h:66 > > + double m_timeLastUsed; > > This is minor. We tend to prefer names where the adjective/verb comes before > the noun. Maybe a better name for this instance variable would be > m_lastUsedTime?
Thanks for the comment, adjusted the names so they make a tad more sense.
Zan Dobersek
Comment 5
2015-12-10 00:47:35 PST
Created
attachment 267077
[details]
Patch for landing Patch for landing, including an attempt to fix the Windows EWS bot.
WebKit Commit Bot
Comment 6
2015-12-10 00:49:29 PST
Attachment 267077
[details]
did not pass style-queue: ERROR: Source/WebCore/platform/graphics/texmap/BitmapTexturePool.cpp:50: More than one command on the same line [whitespace/newline] [4] ERROR: Source/WebCore/platform/graphics/texmap/BitmapTexturePool.cpp:77: More than one command on the same line [whitespace/newline] [4] Total errors found: 2 in 4 files If any of these errors are false positives, please file a bug against check-webkit-style.
Zan Dobersek
Comment 7
2015-12-10 02:23:28 PST
Comment on
attachment 267077
[details]
Patch for landing Clearing flags on attachment: 267077 Committed
r193897
: <
http://trac.webkit.org/changeset/193897
>
Zan Dobersek
Comment 8
2015-12-10 02:23:38 PST
All reviewed patches have been landed. Closing bug.
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug