Bug 152029 - inspector/debugger/command-line-api-exception.html flakily times out on mac
Summary: inspector/debugger/command-line-api-exception.html flakily times out on mac
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 152487 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-12-08 17:21 PST by Ryan Haddad
Modified: 2016-07-02 20:34 PDT (History)
8 users (show)

See Also:


Attachments
[PATCH] Proposed Fix (22.52 KB, patch)
2016-06-30 20:17 PDT, Joseph Pecoraro
no flags Details | Formatted Diff | Diff
[PATCH] Proposed Fix (22.19 KB, patch)
2016-07-01 12:33 PDT, Joseph Pecoraro
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2015-12-08 17:21:32 PST
inspector/debugger/command-line-api-exception.html flakily times out on mac

Flakiness dashboard:
<http://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=inspector%2Fdebugger%2Fcommand-line-api-exception.html>

Most recent timeout:
<https://build.webkit.org/builders/Apple%20Yosemite%20Debug%20WK1%20%28Tests%29/builds/9383>

Has happened since being unskipped in r193427
Comment 1 Ryan Haddad 2015-12-08 17:22:00 PST
--- /Volumes/Data/slave/yosemite-debug-tests-wk1/build/layout-test-results/inspector/debugger/command-line-api-exception-expected.txt
+++ /Volumes/Data/slave/yosemite-debug-tests-wk1/build/layout-test-results/inspector/debugger/command-line-api-exception-actual.txt
@@ -1,32 +1,10 @@
 CONSOLE MESSAGE: line 4: TypeError: undefined is not an object (evaluating '[].x.x')
 CONSOLE MESSAGE: line 10: ReferenceError: Can't find variable: variableThatDoesNotExist
-CONSOLE MESSAGE: line 16: SyntaxError: Unexpected token ')'
-CONSOLE MESSAGE: line 22: IndexSizeError: DOM Exception 1: Index or size was negative, or greater than the allowed value.
-CONSOLE MESSAGE: line 27: thrown string
-CONSOLE MESSAGE: line 32: 123.456
-CONSOLE MESSAGE: line 37: null
-CONSOLE MESSAGE: line 42: [object Object]
-CONSOLE MESSAGE: line 47: [object HTMLBodyElement]
-CONSOLE MESSAGE: line 55: CATCHER: TypeError: undefined is not an object (evaluating '[].x.x')
-CONSOLE MESSAGE: line 55: CATCHER: thrown string
-CONSOLE MESSAGE: line 55: CATCHER: [object Object]
+FAIL: Timed out waiting for notifyDone to be called
 Checks that $exception is available and accurate in evaluations when paused on an exception.
 
 BEFORE: $exception => undefined
 PAUSE #1: $exception => TypeError: undefined is not an object (evaluating '[].x.x')
 PAUSE #2: $exception => ReferenceError: Can't find variable: variableThatDoesNotExist
-PAUSE #3: $exception => SyntaxError: Unexpected token ')'
-PAUSE #4: $exception => Error: IndexSizeError: DOM Exception 1
-PAUSE #5: $exception => thrown string
-PAUSE #6: $exception => 123.456
-PAUSE #7: $exception => null
-PAUSE #8: $exception => Object
-PAUSE #9: $exception => body
-PAUSE #10: $exception => TypeError: undefined is not an object (evaluating '[].x.x')
-STEPPED OUT TO CATCH BLOCK: $exception === e ? true
-PAUSE #11: $exception => thrown string
-STEPPED OUT TO CATCH BLOCK: $exception === e ? true
-PAUSE #12: $exception => Object
-STEPPED OUT TO CATCH BLOCK: $exception === e ? true
-AFTER: $exception => undefined
+AFTER: $exception => SyntaxError: Unexpected token ')'
Comment 2 Radar WebKit Bug Importer 2015-12-08 17:22:11 PST
<rdar://problem/23813812>
Comment 3 Ryan Haddad 2015-12-09 08:55:25 PST
Marked as flaky on Mac in <https://trac.webkit.org/r193834>
Comment 4 Joseph Pecoraro 2016-06-30 19:52:50 PDT
This kind of timeout with output sounds like it is actually just really really slow.

I ran the test locally and found an issue with it, so I'm just completely rewriting the test.
Comment 5 Joseph Pecoraro 2016-06-30 20:14:04 PDT
*** Bug 152487 has been marked as a duplicate of this bug. ***
Comment 6 Joseph Pecoraro 2016-06-30 20:17:06 PDT
Created attachment 282509 [details]
[PATCH] Proposed Fix
Comment 7 Brian Burg 2016-07-01 09:20:01 PDT
Comment on attachment 282509 [details]
[PATCH] Proposed Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=282509&action=review

> LayoutTests/inspector/debugger/command-line-api-exception-nested-catch.html:47
> +                if (!WebInspector.debuggerManager.activeCallFrame)

You *probably* could rewrite this using DebuggerManager's promises and avoid the phase thing. See comment below.

> LayoutTests/inspector/debugger/command-line-api-exception.html:36
> +                        WebInspector.debuggerManager.resume();

(applies throughout) Since many DebuggerManager commands return promises, you could do:

WebInspector.debuggerManager.resume().then(resolve, reject);

Internally, it does a single fire listener for the same event. This helps to keep the logic of event ordering inside DebuggerManager for many use cases.
Comment 8 Joseph Pecoraro 2016-07-01 12:33:09 PDT
Created attachment 282569 [details]
[PATCH] Proposed Fix
Comment 9 WebKit Commit Bot 2016-07-02 20:34:03 PDT
Comment on attachment 282569 [details]
[PATCH] Proposed Fix

Clearing flags on attachment: 282569

Committed r202784: <http://trac.webkit.org/changeset/202784>
Comment 10 WebKit Commit Bot 2016-07-02 20:34:07 PDT
All reviewed patches have been landed.  Closing bug.