Bug 15168 - REGRESSION: [Tiger only] Select pop-up menus are drawn split on bugzilla.mozilla.org
Summary: REGRESSION: [Tiger only] Select pop-up menus are drawn split on bugzilla.mozi...
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: https://bugzilla.mozilla.org/enter_bu...
Keywords: InRadar, NeedsReduction, Regression
Depends on:
Blocks:
 
Reported: 2007-09-09 16:28 PDT by David Kilzer (:ddkilzer)
Modified: 2011-11-03 17:38 PDT (History)
2 users (show)

See Also:


Attachments
Screenshot (10.79 KB, image/png)
2007-09-09 16:36 PDT, David Kilzer (:ddkilzer)
no flags Details
Partial reduction (2.00 KB, text/html)
2007-09-09 17:31 PDT, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2007-09-09 16:28:50 PDT
* SUMMARY
Certain pages on http://bugzilla.mozilla.org/ cause select pop-up menus to be drawn split.

* STEPS TO REPRODUCE
1. Launch Safari/WebKit.
2. Go to URL: https://bugzilla.mozilla.org/enter_bug.cgi?product=Bugzilla
3. Scroll down to "Flags" area.

* EXPECTED RESULTS
Select pop-up menus should be drawn normally.

* ACTUAL RESULTS
Select pop-up menus are drawn "split".

* REGRESSION
This is a regression from shipping Safari 2.0.4 (419.3) with original WebKit on Mac OS X 10.4.10 (8R218).

Tested with a local debug build of WebKit r25458 with Safari 3 Public Beta v. 3.0.3 (522.12.1) on Mac OS X 10.4.10 (8R218).
Comment 1 David Kilzer (:ddkilzer) 2007-09-09 16:31:10 PDT
<rdar://problem/5470385>
Comment 2 David Kilzer (:ddkilzer) 2007-09-09 16:36:16 PDT
Created attachment 16237 [details]
Screenshot
Comment 3 David Kilzer (:ddkilzer) 2007-09-09 17:31:32 PDT
Created attachment 16238 [details]
Partial reduction
Comment 4 David Kilzer (:ddkilzer) 2007-09-09 17:38:51 PDT
(In reply to comment #3)
> Created an attachment (id=16238) [edit]
> Partial reduction

NOTE: I added a border to the outer table during the reduction, and it became part of the reduction.  Removing it prevents the bug from occurring, although changing border="0" and cellpadding="1" will preserve but buggy behavior.

The border="1" attribute on the outer table may also have lead me to remove CSS that was contributing to the bug without the border being present.

In any case, this issue seems to be linked to a number of different factors all contributing to create the bug.

Comment 5 Alexey Proskuryakov 2007-09-09 21:48:08 PDT
I cannot reproduce this with r25449 - is the regression that recent? Or is there something else about system configuration that contributes to this?

I'm also using Safari 3 Public Beta v.3.0.3 (522.12.1) on Mac OS X 10.4.10 (8R218).
Comment 6 David Kilzer (:ddkilzer) 2007-09-09 22:38:05 PDT
(In reply to comment #5)
> I cannot reproduce this with r25449 - is the regression that recent? Or is
> there something else about system configuration that contributes to this?
> 
> I'm also using Safari 3 Public Beta v.3.0.3 (522.12.1) on Mac OS X 10.4.10
> (8R218).

No, the regression occurred when the "native" pop-up menus were implemented.

I do have the "Press Tab to highlight each item on a webpage" checked.

I also have the "All Controls" radio button selected in the "Keyboard Shortcuts" tabs in the "Keyboard & Mouse" system pref pane.

I also have "Enable access for assistive devices" checked in the "Universal Access" system pref pane.

Not sure if any of those make a difference or not.

Comment 7 David Kilzer (:ddkilzer) 2007-09-09 22:41:19 PDT
(In reply to comment #5)
> I cannot reproduce this with r25449 - is the regression that recent? Or is
> there something else about system configuration that contributes to this?
> 
> I'm also using Safari 3 Public Beta v.3.0.3 (522.12.1) on Mac OS X 10.4.10
> (8R218).

Using the same software with WebKit Nightly r25449, I can reproduce the issue with the original URL and the reduced test case.
Comment 8 David Kilzer (:ddkilzer) 2007-09-10 03:50:15 PDT
(In reply to comment #5)
> I cannot reproduce this with r25449 - is the regression that recent? Or is
> there something else about system configuration that contributes to this?

I figured it out.  It has to do with the size of the browser window.  Shrink your window horizontally until you see the gap appear in the pop-up menus.
Comment 9 mitz 2008-02-17 14:49:30 PST
I cannot reproduce the bug with Safari 3.0.4 nor with TOT on 10.5.2.
Comment 10 David Kilzer (:ddkilzer) 2008-02-17 15:34:50 PST
(In reply to comment #9)
> I cannot reproduce the bug with Safari 3.0.4 nor with TOT on 10.5.2.

I can still reproduce this with r30353 and Safari 3.0.4 on 10.4.11.  You MUST resize the browser window so that its width is less than the table.  Also reproduces with stock WebKit and Safari 3.0.4 on 10.4.11.
Comment 11 mitz 2008-02-17 16:13:05 PST
(In reply to comment #10)
> You MUST resize the browser window so that its width is less than the table.

I did! I did!

Thanks for testing. I will try on 10.4.11.
Comment 12 David Kilzer (:ddkilzer) 2009-05-24 07:07:46 PDT
Still occurs with Safari 4 Public Beta on Tiger 10.4.11 (8S165).
Comment 13 mitz 2011-11-03 17:38:34 PDT
Tiger is no longer supported.