Bug 15163 - REGRESSION(r25373): Google Mail becomes slow using various IMs
Summary: REGRESSION(r25373): Google Mail becomes slow using various IMs
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P1 Major
Assignee: Nobody
URL:
Keywords: GoogleBug, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-09-08 09:42 PDT by Jiawei Ye
Modified: 2009-02-09 00:13 PST (History)
3 users (show)

See Also:


Attachments
sample file r25585 with Hanin activated (730.70 KB, text/plain)
2007-09-17 07:08 PDT, Jiawei Ye
no flags Details
sampled file when the symptom occurs (629.43 KB, text/plain)
2008-02-25 09:26 PST, Jiawei Ye
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiawei Ye 2007-09-08 09:42:48 PDT
All actions in Gmail becomes delayed. Clicks on buttons has a half-second delay double-clicking or triple-clicking to select word/line is also delayed.
Comment 1 David Kilzer (:ddkilzer) 2007-09-08 10:12:10 PDT
Thanks for the bug report!  However, we need more information.  Which version of Safari are you using?  Are you using a WebKit nightly build as well?

Do you know what causes the actions to be delayed?  Do they work for a while, then get slow later?

Comment 2 Jiawei Ye 2007-09-08 22:14:08 PDT
Safari 3.0.3 (522.12.1) does not exhibit this behavior. r25449 and the one before does this. 

When I login to my Gmail account, r25449 becomes considerably slower than 522.12.1. In the individual mail view, clicking "Archive" button on 522.12.1 returns immediately to the mail list view, when the nightly builds will take 0.5 secs to fire the action (the button turns blue after .5 secs).

Also, 522.12.1 in either mail list view or individual mail view does not warm up my MBP too much (51C as I type) but nightly builds increases the temp to 60C. Might be some changes in the javascript engine.
Comment 3 Jiawei Ye 2007-09-14 11:27:17 PDT
This is getting worse. Today I have downloaded r25552 and "Archive" "Report Spam" and "Delete" buttons have stopped working for one of my mails. Clicking on the buttons will result in 92% CPU usage but no actions are actually fired. 

Please let me know how I can provide more detailed information. Thank you.
Comment 4 Matt Lilek 2007-09-14 12:22:23 PDT
(In reply to comment #3)
> Please let me know how I can provide more detailed information. Thank you.
> 

When this happens, open Terminal and type "sample Safari 10", then upload the file to this bug.
Comment 5 Jiawei Ye 2007-09-17 07:07:24 PDT
I now know why this happens to me and not to most developers :)

I am using this under Traditional Chinese environment and T-Chinese input method Hanin built into 10.4.10. When I press the buttons under with Hanin activated, it will lag and consumes unexpectedly high CPU time. When I switch to English/US, it does not happen at all.
Comment 6 Jiawei Ye 2007-09-17 07:08:52 PDT
Created attachment 16307 [details]
sample file r25585 with Hanin activated

Sampled against r25585 with Hanin IME activated.
Comment 7 Oliver Hunt 2007-09-17 11:18:15 PDT
I can confirm on ToT, i suspect it will happen to all larger pages although i have no real facts to base this opinion upon.  Will try to regress.
Comment 8 Oliver Hunt 2007-09-17 11:30:24 PDT
Okay, the last nightly this behaves correctly in is r25353, the next nightly is slooooww (r25385)
Comment 9 Oliver Hunt 2007-09-17 11:42:31 PDT
Erk, absolutely nothing in the range looks like it should really cause this.  
Comment 10 Oliver Hunt 2007-09-17 13:51:58 PDT
This regression was caused by r25372
Comment 11 Oliver Hunt 2007-09-17 13:57:15 PDT
gah, by 25372 i mean 25373
Comment 12 Oliver Hunt 2007-09-17 14:17:30 PDT
I have confirmed this hits other IMs as well -- notably the Kotoeri based engines.
Comment 13 Oliver Hunt 2007-09-17 14:19:13 PDT
<rdar://problem/5486974>
Comment 14 Matt Lilek 2007-09-18 11:01:02 PDT
Harrison landed a fix for this in r25617.
Comment 15 Matt Lilek 2007-09-18 11:01:24 PDT
And actually closing the bug helps
Comment 16 Oliver Hunt 2007-09-18 11:02:29 PDT
Jiawei can you verify this has been fixed?
Comment 17 Jiawei Ye 2007-09-19 05:26:27 PDT
I can verify that r25634 nightly build works without the lag. But at the same time, I have lost the ability to enter Chinese text into forms.

For example, this bugzilla form is un-inputable if I switch to Hanin. Switching back to English/US does not help. I have to re-open another tab and switch to English/US first to enter text in the form.
Comment 18 Matt Lilek 2007-09-19 06:13:44 PDT
(In reply to comment #17)
> I can verify that r25634 nightly build works without the lag. But at the same
> time, I have lost the ability to enter Chinese text into forms.
> 
> For example, this bugzilla form is un-inputable if I switch to Hanin. Switching
> back to English/US does not help. I have to re-open another tab and switch to
> English/US first to enter text in the form.
> 

Could you file a new bug on that issue?  Make sure to mention that it started happening with that nightly.
Comment 19 Matt Lilek 2007-09-19 08:19:50 PDT
(In reply to comment #18)
> (In reply to comment #17)
> > I can verify that r25634 nightly build works without the lag. But at the same
> > time, I have lost the ability to enter Chinese text into forms.
> > 
> > For example, this bugzilla form is un-inputable if I switch to Hanin. Switching
> > back to English/US does not help. I have to re-open another tab and switch to
> > English/US first to enter text in the form.
> > 
> 
> Could you file a new bug on that issue?  Make sure to mention that it started
> happening with that nightly.
> 

Thanks Jiawei!  It's bug 15239.

I'm going to re-close this bug since the slowness itself is fixed.
Comment 20 Jiawei Ye 2008-02-25 06:58:31 PST
This bug is re-introduced with r30468, persists through r30551
Comment 21 Jiawei Ye 2008-02-25 09:26:03 PST
Created attachment 19349 [details]
sampled file when the symptom occurs

Slowness also occurs when trying to select any text in individual mail.
Comment 22 Jiawei Ye 2008-03-09 19:45:29 PDT
Does not happen with 10.5.2.
Comment 23 Evan 2009-02-08 21:18:51 PST
(In reply to comment #22)
> Does not happen with 10.5.2.
> 

so this bug can be closed then???
Comment 24 Jiawei Ye 2009-02-08 21:22:53 PST
Yes please