Bug 15151 - Computed tr height is incorrect
Summary: Computed tr height is incorrect
Status: RESOLVED DUPLICATE of bug 24971
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tables (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2007-09-06 07:48 PDT by Mike Aizatsky
Modified: 2010-01-24 15:16 PST (History)
2 users (show)

See Also:


Attachments
A test case (829 bytes, text/html)
2007-09-06 07:50 PDT, Mike Aizatsky
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Aizatsky 2007-09-06 07:48:10 PDT
According to http://www.w3.org/TR/REC-CSS2/tables.html#q7 

17.5.3

The height of a 'table-row' element's box is calculated once the user agent has all the cells in the row available: it is the maximum of the row's specified 'height' and the minimum height (MIN) required by the cells. 

Load the attached sample & press the button - tr disappears, though it clearly had a height assigned.

Mozilla has the intended behaviour - tr has its height.
Comment 1 Mike Aizatsky 2007-09-06 07:50:38 PDT
Created attachment 16207 [details]
A test case

Test case attached
Comment 2 mitz 2007-09-06 08:22:58 PDT
Note that if the TR's style attribute is specified in markup (rather then set after parsing), the test case behaves as expected.
Comment 3 Daniel Bates 2010-01-24 15:16:48 PST

*** This bug has been marked as a duplicate of bug 24971 ***