Bug 15124 - mask images are not updated when render objects' bounds change
Summary: mask images are not updated when render objects' bounds change
Status: RESOLVED DUPLICATE of bug 43031
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: https://bugzilla.mozilla.org/show_bug...
Keywords: HasReduction
Depends on: 14639
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-31 09:48 PDT by jay
Modified: 2010-07-27 03:22 PDT (History)
2 users (show)

See Also:


Attachments
demo (974 bytes, image/svg+xml)
2007-08-31 09:49 PDT, jay
no flags Details
simpler test case (460 bytes, image/svg+xml)
2007-09-26 12:28 PDT, Eric Seidel (no email)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description jay 2007-08-31 09:48:52 PDT
the white hole reveals text. when the window is resized the hole does not
change size, until the page is refreshed.

the white hole should resize as the window is changed by the user:

graphics within a viewbox normally maintain scale as the window is resized.

this is demonstrated in the attachment by a black circle which changes size as
the window is resized by the user.
Comment 1 jay 2007-08-31 09:49:58 PDT
Created attachment 16170 [details]
demo
Comment 2 Eric Seidel (no email) 2007-09-26 12:27:19 PDT
I've created a simpler test (which doesn't use <use>) which I'll attach shortly.
Comment 3 Eric Seidel (no email) 2007-09-26 12:28:00 PDT
Created attachment 16401 [details]
simpler test case
Comment 4 Eric Seidel (no email) 2007-12-27 02:36:13 PST
My simpler test seems to pass in TOT, but I'm not sure if it's fully correct.  The original "demo" fails.  I think there was a %-sized <use> regression in TOT which is tracked by a separate bug.  Yes, bug 14639.
Comment 5 Simon Fraser (smfr) 2009-12-16 10:48:53 PST
Seems to work now?
Comment 6 jay 2009-12-16 13:11:52 PST
5 Simon,

unfortunately this is comprehensively broken..
on OS X please try the original demo...

neither example scales any longer...
the point being the mask has to scale
compare opera/mozilla

evidently if neither the object nor mask scale one cannot check this bug...
Comment 7 Simon Fraser (smfr) 2009-12-16 13:22:32 PST
Using a current nightly build, I did not see obvious issues with either test case.
Comment 8 jay 2009-12-16 22:47:43 PST
simon

are you using os x? if so intel or ppc?

what did you observe?

ie have you compared results when resizing window with mozilla and opera?

using os x with ppc and the latest nightly build:

the simpler test does not resize

the demo test  mask is offset

please confirm your observations using ppc or intel
Comment 9 Simon Fraser (smfr) 2009-12-17 08:18:25 PST
The simpler test says "you should only ever see green", and I see just green. Nothing resizes when I resize the window.

It's totally unclear what the 'demo' test should look like, but I do see one big black circle towards the left, which does not coincide with the white circle with text in.
Comment 10 jay 2009-12-17 10:25:02 PST
Simon,

please read the reduced test case code and understand a bug description before commenting....

the code would show you that the size is set as a percentage.
this means it should scale or resize relative to the window.
at the time the simpler test case was created it did, 
there is a regression bug, possibly filed, by me regarding this aspect.

the simplest way to check whether there is a bug when unsure is as suggested in previous comments to check with a standards compliant browser such as opera or mozilla in this instance.

naturally webkit is referred to in other bugs at mozilla and opera in some cases.

Obviously in some instances it is necessary to take the difference to the working group for adjudication, but not in this case afaik.
Comment 11 Nikolas Zimmermann 2010-07-27 03:22:07 PDT
Will be fixed with bug 43031.

*** This bug has been marked as a duplicate of bug 43031 ***