* SUMMARY Provide a way to override the WKWebView remote inspector name.
<rdar://problem/23475086>
Created attachment 265140 [details] [PATCH] Proposed Fix
Attachment 265140 [details] did not pass style-queue: ERROR: Source/WebKit2/UIProcess/WebPageProxy.h:314: The parameter name "name" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/WebCore/page/PageDebuggable.h:57: The parameter name "name" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 2 in 15 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 265140 [details] [PATCH] Proposed Fix Is name reported as the Debuggable's title? I don't see a usage at the WK2 or RemoteInspector side. Otherwise, looks fine to me.
Comment on attachment 265140 [details] [PATCH] Proposed Fix View in context: https://bugs.webkit.org/attachment.cgi?id=265140&action=review > Source/WebCore/page/PageDebuggable.cpp:48 > String PageDebuggable::name() const This is the use on the RemoteInspector side. When pushing a listing we get the name() of each debuggable.
Wouldn't it be better to make this a configuration parameter instead?
Comment on attachment 265140 [details] [PATCH] Proposed Fix View in context: https://bugs.webkit.org/attachment.cgi?id=265140&action=review >> Source/WebCore/page/PageDebuggable.cpp:48 >> String PageDebuggable::name() const > > This is the use on the RemoteInspector side. When pushing a listing we get the name() of each debuggable. Oh, missed that. Thanks.
(In reply to comment #6) > Wouldn't it be better to make this a configuration parameter instead? That would work if we know what to name the view and it will never change. But, I think the idea of this patch is to override crappy page names as the pages are loaded into the WKWebView. Joe?
(In reply to comment #8) > (In reply to comment #6) > > Wouldn't it be better to make this a configuration parameter instead? > > That would work if we know what to name the view and it will never change. > But, I think the idea of this patch is to override crappy page names as the > pages are loaded into the WKWebView. Joe? Yeah, I think it's very feasible that clients will want to change the name dynamically.
Are there any open questions?
<http://trac.webkit.org/changeset/192437>
Follow-up to add Availability Macros: <http://trac.webkit.org/changeset/192446>