Bug 150937 - Regression(r192038): Safari cannot load any pages
Summary: Regression(r192038): Safari cannot load any pages
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P1 Normal
Assignee: Chris Dumez
URL:
Keywords: InRadar
: 150926 (view as bug list)
Depends on:
Blocks: 150898
  Show dependency treegraph
 
Reported: 2015-11-05 10:23 PST by Chris Dumez
Modified: 2015-11-05 13:27 PST (History)
5 users (show)

See Also:


Attachments
Fix (1.56 KB, patch)
2015-11-05 10:29 PST, Chris Dumez
no flags Details | Formatted Diff | Diff
Regression test (2.50 KB, patch)
2015-11-05 11:22 PST, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2015-11-05 10:23:43 PST
Safari cannot load any pages after r192038.
Comment 1 Chris Dumez 2015-11-05 10:24:11 PST
rdar://problem/23413859
Comment 2 Chris Dumez 2015-11-05 10:29:16 PST
Created attachment 264870 [details]
Fix
Comment 3 Chris Dumez 2015-11-05 10:31:44 PST
Comment on attachment 264870 [details]
Fix

Clearing flags on attachment: 264870

Committed r192060: <http://trac.webkit.org/changeset/192060>
Comment 4 Chris Dumez 2015-11-05 10:31:49 PST
All reviewed patches have been landed.  Closing bug.
Comment 5 Simon Fraser (smfr) 2015-11-05 10:43:12 PST
Comment on attachment 264870 [details]
Fix

Why was this not caught by tests?
Comment 6 Chris Dumez 2015-11-05 10:48:39 PST
(In reply to comment #5)
> Comment on attachment 264870 [details]
> Patch
> 
> Why was this not caught by tests?

I think because this relies on load deferring. I am looking into adding an internals API that would enable load deferring so we can add test coverage for this.
Comment 7 Chris Dumez 2015-11-05 10:53:25 PST
(In reply to comment #6)
> (In reply to comment #5)
> > Comment on attachment 264870 [details]
> > Patch
> > 
> > Why was this not caught by tests?
> 
> I think because this relies on load deferring. I am looking into adding an
> internals API that would enable load deferring so we can add test coverage
> for this.

Actually, there is already testRunner.setDefersLoading(bool). I will see if I can add coverage for this bug using this API.
Comment 8 Chris Dumez 2015-11-05 11:22:36 PST
Reopening to attach new patch.
Comment 9 Chris Dumez 2015-11-05 11:22:38 PST
Created attachment 264872 [details]
Regression test
Comment 10 Geoffrey Garen 2015-11-05 11:23:49 PST
Comment on attachment 264872 [details]
Regression test

r=me
Comment 11 WebKit Commit Bot 2015-11-05 12:38:19 PST
Comment on attachment 264872 [details]
Regression test

Clearing flags on attachment: 264872

Committed r192069: <http://trac.webkit.org/changeset/192069>
Comment 12 WebKit Commit Bot 2015-11-05 12:38:23 PST
All reviewed patches have been landed.  Closing bug.
Comment 13 Alexey Proskuryakov 2015-11-05 13:27:03 PST
*** Bug 150926 has been marked as a duplicate of this bug. ***