The function is supposed to only generate code to do arithmetic on numeric types. Naming it compileArithAdd() is more accurate, and is consistent with the name of the node it emits code for (i.e. ArithAdd) as well as other compiler functions for analogous operations e.g. compileArithSub.
Created attachment 264748 [details]
Comment on attachment 264748 [details]
Clearing flags on attachment: 264748
Committed r192000: <http://trac.webkit.org/changeset/192000>
All reviewed patches have been landed. Closing bug.