Bug 15067 - REGRESSION: Playing stops after each song at deezer.com
Summary: REGRESSION: Playing stops after each song at deezer.com
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://www.deezer.com/
Keywords: InRadar, NeedsReduction, Regression
Depends on:
Blocks:
 
Reported: 2007-08-24 01:16 PDT by Maxime BRITTO
Modified: 2009-11-27 12:26 PST (History)
5 users (show)

See Also:


Attachments
Memory Usage Screenshot (128.72 KB, image/tiff)
2007-08-28 01:51 PDT, Maxime BRITTO
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maxime BRITTO 2007-08-24 01:16:18 PDT
When playing a song from a list (album list, or even playlist) at deezer.com, the playing stops at the end of the song instead of playing the next song.

Steps to reproduce:
1 - Go to www.deezer.com
2 - Search for some artist in the search bar
3 - Play one of the songs

Expected behavior :
At the end of the song, the next song should be loaded and played.

Observed behavior :
The playing stops and we have to choose the next song manually

Regression :
I am using the latest WebKit (r25213) and Safari 2.0.4.This problem does not append on shipping Safari.

Comments :
 - There is a JS error but it is on both nightly and shipping : http://www.deezer.com/fr/ line 35: ReferenceError: Can't find variable: zS
Comment 1 Maxime BRITTO 2007-08-24 01:24:02 PDT
There may be a memory issue too with this website, but I'm not sure for now :
Yesterday I was using this site all day long and I had to quit Safari two times because he was using a huge amout of virtual memory (10Go the first time and 2,5Go the second time)
I'm not sure because I was doing other things on the main time and the memory use of Safari was growing slowly.
I was using the rev 25196.Today I'll use the shipping version to see if this problem still occurs.
Comment 2 Mark Rowe (bdash) 2007-08-25 02:56:52 PDT
(In reply to comment #1)
> There may be a memory issue too with this website, but I'm not sure for now :
> Yesterday I was using this site all day long and I had to quit Safari two times
> because he was using a huge amout of virtual memory (10Go the first time and
> 2,5Go the second time)

There's no way that Safari was using 10GB of virtual memory.  On 32-bit machines the maximum address space a process has access to is 4GB.  Any attempts to allocate more memory than this will result in allocation failures, and will quickly cause the program to crash.  I suspect the high memory usage you are seeing is related to the use of Flash, in which case there is another bug in Bugzilla that covers this issue.

The site loads *incredibly* slowly for me so I am not able to easily verify your original bug report.
Comment 3 Maxime BRITTO 2007-08-28 01:21:12 PDT
(In reply to comment #2)
> There's no way that Safari was using 10GB of virtual memory.  On 32-bit
> machines the maximum address space a process has access to is 4GB.  Any
> attempts to allocate more memory than this will result in allocation failures,
> and will quickly cause the program to crash.  I suspect the high memory usage
> you are seeing is related to the use of Flash, in which case there is another
> bug in Bugzilla that covers this issue.

You're probably right about the flash plugin culpability but I'm sure Safari was using 10Go of virtual memory (according to the Activity Monitor). And by the way I'm using a Core Duo which is a 64 bit cpu. I'll try to reproduce and to take a screenshot today.

> 
> The site loads *incredibly* slowly for me so I am not able to easily verify
> your original bug report.
> 

The site just got open, and it seems that the number of connection was crazy last week. Maybe it will be better this week.
Comment 4 Maxime BRITTO 2007-08-28 01:51:02 PDT
Created attachment 16141 [details]
Memory Usage Screenshot

Here is a screenshot of the Activity Monitor after 5 songs played on deezer.com with Safari 2.0.4 and WebKit r 25269
Comment 5 Mark Rowe (bdash) 2007-08-28 01:56:11 PDT
You're using a 64-bit CPU to run a 32-bit application, which means the application address space is still limited as I described.  I'd be interested to see how much virtual memory 'top' or 'ps auxww' reports Safari as using.  You may have hit a bug in Activity Monitor.

The URL mentioned in the bug report is still very slow.  I'll try again in a day or two to see if I can reproduce the problem.
Comment 6 Adele Peterson 2007-08-30 17:21:33 PDT
Filed <rdar://problem/5452175> to track the original problem.
Comment 7 choongx 2008-10-15 16:02:20 PDT
No repro on: r37605, Leopard Intel, Flash 10
Comment 8 adambilbrough 2009-07-23 17:01:25 PDT
This appears to be fixed now (July 23rd 2009) using WebKit-SVN-r46282 and Safari 4.0.2 on Mac OS X 10.5.7.

Using a playlist functions as one would expect and the next song loads and plays right after the previous song has finished.  Songs and playlists continue to play while browsing Deezer.com and change once a user selects a different song or playlist.

Recommend REGRESSION from other users to verify that this is correct.
Comment 9 Adele Peterson 2009-11-27 12:26:39 PST
Also looks fixed to me.