Bug 150469 - remove 350ms touch > mouse events delay for width=device-width viewport
Summary: remove 350ms touch > mouse events delay for width=device-width viewport
Status: RESOLVED DUPLICATE of bug 150604
Alias: None
Product: WebKit
Classification: Unclassified
Component: Event Handling (show other bugs)
Version: WebKit Nightly Build
Hardware: iPhone / iPad Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-22 13:40 PDT by Patrick H. Lauke
Modified: 2015-10-27 17:01 PDT (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick H. Lauke 2015-10-22 13:40:55 PDT
(opening this as a separate issue from https://bugs.webkit.org/show_bug.cgi?id=122212)

Chrome [1], Firefox and MS Edge currently remove the 300-350ms delay between touchend and the mouse compatibility events (see [2]) for "mobile optimized" pages that have a viewport of width=device-width.
Pages are still zoomable using pinch-to-zoom, but not double-tap-to-zoom. Supporting this in iOS would obviate the need for mobile sites to use tricks such as fastclick.js

Although a more declarative method will now be available with touch-action:manipulation [3], it may still be worth considering this for compatibility with the other major browsers (and the fact that it's arguably the path of least resistance for developers: support for this would mean that sites which currently use width=device-width and fastclick.js can simply remove the latter, vs removing fastclick AND explicitly adding touch-action:manipulation).

[1] https://developers.google.com/web/updates/2013/12/300ms-tap-delay-gone-away?hl=en
[2] http://patrickhlauke.github.io/touch/tests/results/#suppressing-300ms-delay
[3] https://bugs.webkit.org/show_bug.cgi?id=149854
Comment 1 Patrick H. Lauke 2015-10-22 13:48:17 PDT
Copying over a useful comment from rbyers from https://bugs.webkit.org/show_bug.cgi?id=122212 which provides some hard data

"Some usage data from Chrome which may be helpful in having a data-oriented debate here: 
 - only 0.6% of taps lead to a double tap
   - rises to 3.5% considering only sites where double tap is enabled
 - 75% (and increasing) of pages loaded on Android have a mobile viewport
 - 84% of taps (and increasing) occur on pages with a mobile viewport"
Comment 2 Wenson Hsieh 2015-10-27 17:01:28 PDT

*** This bug has been marked as a duplicate of bug 150604 ***