Bug 150329 - Strange characters when using OpenType ligatures and soft hyphens
Summary: Strange characters when using OpenType ligatures and soft hyphens
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: Safari 9
Hardware: Macintosh OS X 10.11
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-19 07:11 PDT by Mathias Nater
Modified: 2015-10-21 08:05 PDT (History)
2 users (show)

See Also:


Attachments
reduction showing the described bug (1.41 KB, text/html)
2015-10-19 07:11 PDT, Mathias Nater
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Nater 2015-10-19 07:11:55 PDT
Created attachment 263480 [details]
reduction showing the described bug

If a text is rendered with an OpenType font supporting the "liga" feature (e.g. Source Sans Pro) and this text also contains soft hyphens, strange characters are displayed around the soft hyphens following a ligature on the same rendered line.

If ligatures are disabled by -webkit-font-variant-ligatures: no-common-ligatures; or -webkit-font-feature-settings: "liga" 0; text is displayed correctly.
Comment 1 Myles C. Maxfield 2015-10-20 10:58:01 PDT
Please try in a nightly build. I think I fixed this in http://trac.webkit.org/changeset/190891
Comment 2 Mathias Nater 2015-10-20 11:35:02 PDT
I tested the above in WebKit-SVN-r191175 and now in WebKit-SVN-r191340: no changes.

Although I'm not sure if this is really the nightly build since "About Safari" says "Version 9.0 (11601.1.56)" when I launch the nightly build. Is that normal or did I make a mistake?
Comment 3 Alexey Proskuryakov 2015-10-20 12:49:18 PDT
Unfortunately, nightly builds don't currently work on OS X El Capitan.

As far as I know, they should work if you temporarily disable System Integrity Protection.
Comment 4 Mathias Nater 2015-10-21 08:05:48 PDT
It's very unfortunate that there's no note about nightlies not working on El Capitan on nightly.webkit.org

I used the workaround on https://trac.webkit.org/wiki/WebKitNightlyElCapWorkaround and now I can confirm that this bug has been fixed indeed.

Thanks for the fix and sorry for the double post.

Kind regards,
Mathias