Bug 15017 - ASSERTION FAILED: size == 0 || size >= m_encodedSize in WebCore::CachedResource::setEncodedSize
Summary: ASSERTION FAILED: size == 0 || size >= m_encodedSize in WebCore::CachedResour...
Status: RESOLVED DUPLICATE of bug 15191
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://laserjock.wordpress.com/2007/0...
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-19 23:35 PDT by Matt Lilek
Modified: 2007-09-12 11:25 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Lilek 2007-08-19 23:35:08 PDT
I'm hitting this assert when I middle click the four thumbnails towards the top of this page to open them in background tabs.  size >= m_encodedSize is causing this to be hit.

ASSERTION FAILED: size == 0 || size >= m_encodedSize
(/Users/matt/Code/WebKit/WebCore/loader/CachedResource.cpp:159 void WebCore::CachedResource::setEncodedSize(unsigned int))

Thread 0 Crashed:
0   com.apple.WebCore              	0x0112d9d8 WebCore::CachedResource::setEncodedSize(unsigned) + 132 (CachedResource.cpp:159)
1   com.apple.WebCore              	0x0112d12c WebCore::CachedImage::data(WTF::PassRefPtr<WebCore::SharedBuffer>, bool) + 396 (CachedImage.cpp:197)
2   com.apple.WebCore              	0x01130ab4 WebCore::Loader::didReceiveData(WebCore::SubresourceLoader*, char const*, int) + 372 (loader.cpp:208)
3   com.apple.WebCore              	0x01492d60 WebCore::SubresourceLoader::didReceiveData(char const*, int, long long, bool) + 180 (SubresourceLoader.cpp:180)
4   com.apple.WebCore              	0x01490d50 WebCore::ResourceLoader::didReceiveData(WebCore::ResourceHandle*, char const*, int, int) + 108
5   com.apple.WebCore              	0x0146472c -[WebCoreResourceHandleAsDelegate connection:didReceiveData:lengthReceived:] + 300 (ResourceHandleMac.mm:422)
6   com.apple.Foundation           	0x92c13624 -[NSURLConnection(NSURLConnectionInternal) _sendDidReceiveDataCallback] + 564
7   com.apple.Foundation           	0x92c11ac4 -[NSURLConnection(NSURLConnectionInternal) _sendCallbacks] + 488
Comment 1 Geoffrey Garen 2007-08-20 15:54:52 PDT
I couldn't reproduce this.

The backtrace shows that you were loading a subresource for a webpage, but clicking a thumbnail on this site opens a stand-alone image, not a webpage. Are you sure you have the steps to reproduce right?
Comment 2 Matt Lilek 2007-08-20 16:39:18 PDT
I can't reproduce this now either, but I definitely could last night.  One difference I noticed is that now there's that bloody annoying snap preview crap which I think was timing out last night or wasn't otherwise appearing.

I'll leave this open for now and try it a couple more times then close it if I can't reproduce.
Comment 3 Matt Lilek 2007-08-26 09:19:45 PDT
I just hit this again when opening <http://bugs.webkit.org/attachment.cgi?id=16123&action=view> from Mail to Safari 3.0.3 Beta with r25251 on Tiger.
Comment 4 mitz 2007-09-12 10:55:33 PDT
Bug 15191 is in Radar.

*** This bug has been marked as a duplicate of 15191 ***