We're passing freeSpaceForRows and freeSpaceForColumns to a bunch of functions along with the GridSizingData struct when we should really include them both in the struct as we're talking about temporary data that is only used for the layout process.
Created attachment 262610 [details]
Comment on attachment 262610 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=262610&action=review
Need a new patch; looks like this one doesn’t build.
> + GridSizingData(unsigned gridColumnCount, unsigned gridRowCount, const LayoutUnit& freeSpaceForColumns, const LayoutUnit& freeSpaceForRows)
LayoutUnit is small enough that we probably want to just pass LayoutUnit, not const LayoutUnit&.
> + const_cast<RenderGrid*>(this)->computeUsedBreadthOfGridTracks(ForColumns, sizingData);
The const_cast in this function is strange. Doesn’t seem like the right pattern for functions with side effects. Not new to this patch, though.
(In reply to comment #2)
> Comment on attachment 262610 [details]
> View in context:
> Need a new patch; looks like this one doesn’t build.
Beh, I somehow committed a patch without one of the replacements.
Created attachment 262688 [details]
Committed r190784: <http://trac.webkit.org/changeset/190784>