Bug 149821 - GC shouldn't cancel every FTL compilation
Summary: GC shouldn't cancel every FTL compilation
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Filip Pizlo
URL:
Keywords:
Depends on: 149836
Blocks: 149823
  Show dependency treegraph
 
Reported: 2015-10-05 15:46 PDT by Filip Pizlo
Modified: 2017-03-14 21:03 PDT (History)
3 users (show)

See Also:


Attachments
the patch (3.91 KB, patch)
2015-10-05 16:00 PDT, Filip Pizlo
sbarati: review+
Details | Formatted Diff | Diff
performance (77.42 KB, text/plain)
2015-10-05 17:01 PDT, Filip Pizlo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Pizlo 2015-10-05 15:46:28 PDT
Patch forthcoming.
Comment 1 Filip Pizlo 2015-10-05 16:00:26 PDT
Created attachment 262474 [details]
the patch
Comment 2 Saam Barati 2015-10-05 16:42:54 PDT
Comment on attachment 262474 [details]
the patch

View in context: https://bugs.webkit.org/attachment.cgi?id=262474&action=review

r=me

> Source/JavaScriptCore/dfg/DFGPlan.cpp:648
> +    // NOTE: From here on, this method can return anything and still be sounds. It's sound to return

"be sounds" => "be sound"
Comment 3 Filip Pizlo 2015-10-05 17:01:38 PDT
Created attachment 262481 [details]
performance
Comment 4 Filip Pizlo 2015-10-05 18:38:17 PDT
Landed in http://trac.webkit.org/changeset/190599
Comment 5 Alexey Proskuryakov 2015-10-05 23:08:46 PDT
This made many perf tests randomly crash, rolling out.

https://build.webkit.org/builders/Apple%20Mavericks%20Release%20WK2%20(Perf)?numbuilds=50

Oct 05 21:15	190602	failure	#5939	Failed 11 perf tests failed
Oct 05 19:42	190599	failure	#5938	Failed 10 perf tests failed
Oct 05 17:23	190589	failure	#5937	Failed 2 perf tests failed
Oct 05 15:04	190579	success	#5936	Build successful
Oct 05 12:45	190567	failure	#5935	Failed 1 perf tests failed
Oct 05 10:20	190560	success	#5934	Build successful

https://build.webkit.org/builders/Apple%20Yosemite%20Release%20WK2%20(Perf)?numbuilds=50

Oct 05 21:19	190601	failure	#3076	Failed 9 perf tests failed
Oct 05 19:13	190597	failure	#3075	Failed 1 perf tests failed
Oct 05 17:01	190587	success	#3074	Build successful

https://build.webkit.org/builders/Apple%20El%20Capitan%20Release%20WK2%20(Perf)?numbuilds=50

Oct 05 21:15	190601	failure	#47	Failed 7 perf tests failed
Oct 05 19:15	190597	failure	#46	Failed 1 perf tests failed
Oct 05 17:08	190591	failure	#45	Failed 1 perf tests failed
Oct 05 14:58	190579	success	#44	Build successful


Thread 10 Crashed:: WTF Parallel Helper Thread
0   com.apple.JavaScriptCore      	0x000000011122daca JSC::speculationFromCell(JSC::JSCell*) + 58
1   com.apple.JavaScriptCore      	0x0000000110c52e72 JSC::CodeBlock::updateAllPredictionsAndCountLiveness(unsigned int&, unsigned int&) + 258
2   com.apple.JavaScriptCore      	0x0000000110c4fa07 JSC::CodeBlock::stronglyVisitStrongReferences(JSC::SlotVisitor&) + 567
3   com.apple.JavaScriptCore      	0x0000000110c4f786 JSC::CodeBlock::visitChildren(JSC::SlotVisitor&) + 342
4   com.apple.JavaScriptCore      	0x0000000111229ff5 JSC::SlotVisitor::drain() + 277
5   com.apple.JavaScriptCore      	0x000000011122a1f8 JSC::SlotVisitor::drainFromShared(JSC::SlotVisitor::SharedDrainMode) + 104
6   com.apple.JavaScriptCore      	0x0000000110f2d86d WTF::SharedTaskFunctor<JSC::Heap::markRoots(double, void*, void*, int (&) [37])::$_0>::run() + 285
7   com.apple.JavaScriptCore      	0x00000001112cd56c WTF::ParallelHelperClient::runTask(WTF::RefPtr<WTF::SharedTask>) + 44
8   com.apple.JavaScriptCore      	0x00000001112cdd30 WTF::ParallelHelperPool::helperThreadBody() + 224
9   com.apple.JavaScriptCore      	0x00000001112dd593 WTF::threadEntryPoint(void*) + 179
10  com.apple.JavaScriptCore      	0x00000001112dd9cf WTF::wtfThreadEntryPoint(void*) + 15
Comment 6 WebKit Commit Bot 2015-10-05 23:10:46 PDT
Re-opened since this is blocked by bug 149836
Comment 7 Alexey Proskuryakov 2015-10-05 23:11:55 PDT
Another stack trace from a bot; I'm not sure which is caused by this, and which by bug 149727.

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.apple.JavaScriptCore      	0x0000000111c90cde WTFCrash + 62
1   com.apple.JavaScriptCore      	0x000000011163a8ed JSC::CodeBlock::setOptimizationThresholdBasedOnCompilationResult(JSC::CompilationResult) + 877
2   com.apple.JavaScriptCore      	0x00000001119e7c46 JSC::JITToDFGDeferredCompilationCallback::compilationDidComplete(JSC::CodeBlock*, JSC::CodeBlock*, JSC::CompilationResult) + 150
3   com.apple.JavaScriptCore      	0x000000011186c4c1 JSC::DFG::Worklist::completeAllReadyPlansForVM(JSC::VM&, JSC::DFG::CompilationKey) + 257
4   com.apple.JavaScriptCore      	0x00000001119c9757 operationOptimize + 727
5   ???                           	0x000032e6adc4836e 0 + 55966339203950
6   ???                           	0x000032e6adc15fc0 0 + 55966338998208
7   com.apple.JavaScriptCore      	0x0000000111ae3f7c vmEntryToJavaScript + 299
8   com.apple.JavaScriptCore      	0x00000001119aa9ae JSC::JITCode::execute(JSC::VM*, JSC::ProtoCallFrame*) + 158
9   com.apple.JavaScriptCore      	0x0000000111986e95 JSC::Interpreter::executeCall(JSC::ExecState*, JSC::JSObject*, JSC::CallType, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&) + 453
10  com.apple.JavaScriptCore      	0x000000011161b007 JSC::call(JSC::ExecState*, JSC::JSValue, JSC::CallType, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&, WTF::NakedPtr<JSC::Exception>&) + 71
11  com.apple.WebCore             	0x0000000112e58019 WebCore::ScheduledAction::executeFunctionInContext(JSC::JSGlobalObject*, JSC::JSValue, WebCore::ScriptExecutionContext&) + 537 (JSMainThreadExecState.h:93)
12  com.apple.WebCore             	0x0000000112e57c5a WebCore::ScheduledAction::execute(WebCore::Document&) + 138 (ScheduledAction.cpp:125)
13  com.apple.WebCore             	0x0000000112426cf9 WebCore::DOMTimer::fired() + 553 (InspectorInstrumentation.h:284)
Comment 8 Filip Pizlo 2017-03-14 21:03:41 PDT
This got fixed.