Bug 14962 - signed out when browsing categories on ebay.de
Summary: signed out when browsing categories on ebay.de
Status: RESOLVED DUPLICATE of bug 3512
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 419.x
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://audio.listings.ebay.de
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2007-08-14 03:23 PDT by Christian Eckert
Modified: 2007-11-03 23:44 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Eckert 2007-08-14 03:23:45 PDT
When signed in to www.ebay.de, every time a category listing is being loaded I get signed out. Both PPC and Intel versions of Safari (2.0.4, 419.3) are affected under 10.4. Works ok with Camino (Intel) under 10.4 and Safari (PPC) under 10.3. No problems like that at all are encountered on ebay.com or ebay.co.uk. The main adress "listings.ebay.de" seems to be functional, choosing a specific category listing (as mentioned in the URL field as an example) and clicking any provided link on the displayed page will end in being signed out. This makes Safari quite unusable with the german ebay pages, unfortunately.
Comment 1 David Kilzer (:ddkilzer) 2007-08-14 05:00:13 PDT
Have you tried using a WebKit nightly build?  (It doesn't require any installation--just download the DMG and run the app with the gold Safari icon.)

http://nightly.webkit.org/

You might also try the Safari 3 Public Beta for Mac OS X to see if that fixes the issue.

http://apple.com/safari/

Comment 2 David Kilzer (:ddkilzer) 2007-08-14 05:04:13 PDT
This could also be related to a cookie issue (like Bug 3512).

Comment 3 David Kilzer (:ddkilzer) 2007-08-14 05:12:33 PDT
Confirmed with a local debug build of WebKit r25066 with Safari 3 Public Beta v. 3.0.3 (522.12.1) on Mac OS X 10.4.10 (8R218).  This definitely looks like a cookie-related issue.

Sorry, trying the WebKit nightly build or the Safari 3 Public Beta won't fix this issue (although it should improve your overall browsing experience if you'd still like to try it).

Note that an ebay.com account works just fine for logging into ebay.de, which makes testing much easier!

* STEPS TO REPRODUCE
1. Launch Safari/WebKit.
2. Go to URL:  http://www.ebay.de/
3. Click on the "Einloggen" (login) link.
4. Enter your ebay.com username and password, then click the "Sicheres Einloggen >" button.
5. Click on a "Kategorien" (category) link on the left (like "Baby").
6. Note that you're still logged in ("Hallo, username" by the eBay logo in the upper left).
7. Click on a sub-category link like "Bettausstattung".

* RESULTS
Note that you're now logged out ("Hallo! Einloggen oder Anmelden." by the eBay logo in the upper left).

Comment 4 Christian Eckert 2007-08-14 05:17:46 PDT
(In reply to comment #1)
The latest nightly build shows the same effect (r25065), I was taking care of that before filing the bug.
Comment 5 David Kilzer (:ddkilzer) 2007-08-14 05:26:54 PDT
Unfortunately this is another case of Bug 3512.

Basically what happens is that a number of cookies are set for the ".ebay.de" domain, but Safari (using the Foundation framework) fails to send these cookies for domains with more than three parts (like "baby.listings.ebay.de").  When this happens, the ebay.de site assumes you are not logged in, and sends new cookies back that effectively log you out by erasing your session cookies.  (Not sure if that made any sense, but it's what happens on a technical level.)

This is a known regression in Tiger (Mac OS X 10.4) that works in Panther (10.3) and is fixed again in Leopard (10.5).

If you would like to see this fixed for Tiger, I suggest you file a bug with Apple's internal bug tracking tool (Radar) using <http://bugreport.apple.com/>.  You may sign up for a free "online" account to log in using <http://connect.apple.com/>.



*** This bug has been marked as a duplicate of 3512 ***

*** This bug has been marked as a duplicate of 3512 ***
Comment 6 Christian Eckert 2007-08-14 15:03:43 PDT
David, thank you for investigating this bug. I will file it to be repaired in 10.4 though I don't think this will happen. Thank you for the kind and understandable explanation. Seems like Camino has to be preferred over Safari in this case. I will file the bug at bugreport.apple.com as soon as the website is up and running again.
Comment 7 David Kilzer (:ddkilzer) 2007-08-15 05:42:59 PDT
For posterity, note that *EVERY* localized eBay site that uses the form "ebay.cc" (where "cc" is a two-character ISO country code) is affected by this bug.  And since you may use your eBay account on all of them to test, it's easy to verify this.

http://ebay.at/   [Austria]
http://ebay.ca/   [Canada]
http://ebay.de/   [Germany]
http://ebay.es/   [Spain]
http://ebay.fr/   [France]
http://ebay.ie/   [Ireland]
http://ebay.in/   [India]
http://ebay.it/   [Italy]
http://ebay.nl/   [The Netherlands]
http://ebay.pl/   [Poland]

And so on.

For Belgium's site (http://ebay.be/), you can't even log in due to this bug.  When accessing ebay.be, you must choose between French (http://www.befr.ebay.be/) and Dutch (http://www.benl.ebay.be/) languages.  After signing in, you're redirected to http://my.befr.ebay.be/ (French) or http://my.benl.ebay.be/ (Dutch), where Safari fails to send cookies due to this bug, after which the web site immediately logs you back out and returns you to the login page.
Comment 8 Christian Eckert 2007-08-16 00:49:49 PDT
This issue is filed in Radar as bug #5412143:

5412143 | international ebay sites can't be used with Safari | Mac OS X | Other Bug | 15-Aug-2007 05:33 AM | Open
Comment 9 David Kilzer (:ddkilzer) 2007-11-03 23:44:35 PDT
(In reply to comment #8)
> This issue is filed in Radar as bug #5412143:
> 
> 5412143 | international ebay sites can't be used with Safari | Mac OS X | Other
> Bug | 15-Aug-2007 05:33 AM | Open

Fixed in Mac OS X 10.5 Leopard.