Bug 14957 - Navigation of www.sfgate.com is broken
: Navigation of www.sfgate.com is broken
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Page Loading
: 523.x (Safari 3)
: All All
: P2 Normal
Assigned To: Nobody
http://www.sfgate.com/
: InRadar, ReviewedForRadar
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-13 10:24 PDT by Sridhar Gurivireddy
Modified: 2009-03-31 17:44 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sridhar Gurivireddy 2007-08-13 10:24:36 PDT
Navigation of some news links in www.sfgate.com causes "Back/forward" links to not work and Safari eventually gives up asking user to report the issue to Apple.

Safari can’t open the page.
Safari can’t open the page “http://www.sfgate.com/cgi-bin/article.cgi?f=/c/a/2007/08/13/BAE6RGM7G.DTL”. The error was: “unknown error” ((null):10053) Please choose Report Bugs to Apple from the Help menu, note the error number, and describe what you did before you saw this message.
Comment 1 David Kilzer (:ddkilzer) 2007-08-13 23:13:19 PDT
I do see an issue where you must hit Back twice to actually go back a page (after clicking on an article), but not the behavior described above.

What version of Safari are you using?  Could you write exact steps to reproduce the issue you're seeing?
Comment 2 Sridhar Gurivireddy 2007-08-18 03:00:27 PDT
Repro steps

1) Navigate to sfgate.com
2) Click on any news article
3) Navigate back! (Back navigation does not work).

This works in other browsers on windows,
Comment 3 David Kilzer (:ddkilzer) 2007-08-18 14:44:54 PDT
Confirmed that hitting back once doesn't go back to the previous page.

Changing Component to Page Loading.

Seems to be a cross-platform issue, so changing Hardware/OS to All.

Comment 4 David Kilzer (:ddkilzer) 2007-08-29 18:07:27 PDT
<rdar://problem/5448982>
Comment 5 John Sullivan 2007-08-30 11:13:30 PDT
This was already in radar as <rdar://problem/5333496>, except the part about the unknown error. Is that part still happening?
Comment 6 Robert Blaut 2009-01-02 12:13:07 PST
I cannot reproduce the reported issue in WebKit r39524.
Comment 7 Darin Adler 2009-03-31 17:44:35 PDT
http://trac.webkit.org/changeset/25410