Bug 14942 - FreeTextBox rich text editor does not support WebKit
Summary: FreeTextBox rich text editor does not support WebKit
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.freetextbox.com/
Keywords:
: 14934 (view as bug list)
Depends on: 14943
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-11 07:56 PDT by David Kilzer (:ddkilzer)
Modified: 2008-12-22 15:05 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2007-08-11 07:56:03 PDT
* SUMMARY
The FreeTextBox rich text editor degrades to a simple textarea when used with WebKit/Safari.

* STEPS TO REPRODUCE
1. Launch Safari/WebKit.
2. Go to URL: http://www.freetextbox.com/
3. Click on the FreeTextBox 3.0 image.

* EXPECTED RESULTS
A full rich text editor should be available for Safari/WebKit.

* ACTUAL RESULTS
A fallback textarea is presented.

* NOTES
Creating this as an evangelism bug as other rich text editors (TinyMCE in Bug 6627, FCKEditor in Bug 9915) now have beta or full support for WebKit.

If there are any features that WebKit does not currently support that are needed for FreeTextBox, please file separate bugs and make them block this bug.
Comment 1 David Kilzer (:ddkilzer) 2007-08-11 08:04:53 PDT
Safari support requests in FreeTextBox support forums:

http://freetextbox.com/search/SearchResults.aspx?q=safari&s=19

Comment 2 David Kilzer (:ddkilzer) 2007-08-11 08:11:33 PDT
Contacted freetextbox.com about this bug using:  http://freetextbox.com/contact/

Comment 3 David Kilzer (:ddkilzer) 2007-08-11 08:27:39 PDT
*** Bug 14934 has been marked as a duplicate of this bug. ***
Comment 4 David Kilzer (:ddkilzer) 2007-08-16 06:57:14 PDT
Per private email from John Dyer at FreeTextBox.com, WebKit/Safari support should be available in September.

Comment 5 Robert Blaut 2008-02-11 01:04:31 PST
It's February 2008 and the bug is still present :(
Comment 6 David Kilzer (:ddkilzer) 2008-02-11 18:10:17 PST
(In reply to comment #4)
> Per private email from John Dyer at FreeTextBox.com, WebKit/Safari support
> should be available in September.

Via private email, John told me that a beta release of FreeTextBox is available that supports Safari, but there are still some issues to resolve before a final release.

Comment 7 Robert Blaut 2008-12-22 13:28:12 PST
The bug is fixed. According a page http://freetextbox.com/features/ Webkit is supported by freetextbox. Demo page also works fine. 
Comment 8 David Kilzer (:ddkilzer) 2008-12-22 15:05:10 PST
W00t!