Bug 149345 - Web Inspector: Array values after 100 aren't shown
Summary: Web Inspector: Array values after 100 aren't shown
Status: RESOLVED DUPLICATE of bug 143589
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Local Build
Hardware: All All
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2015-09-18 07:42 PDT by Nikita Vasilyev
Modified: 2015-09-18 12:10 PDT (History)
7 users (show)

See Also:


Attachments
[Animated GIF] Bug (245.11 KB, image/gif)
2015-09-18 07:42 PDT, Nikita Vasilyev
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Vasilyev 2015-09-18 07:42:16 PDT
Created attachment 261502 [details]
[Animated GIF] Bug

Steps:
1. (new Array(200)).fill(42)
2. Expand the array preview

Expected:
There should be a way to see array items after first 100.

Actual:
Only first 100 items are show. When the array is expanded, it can be easily misinterpreted that there are exactly 100 items. There is no way to load another 100 or anything like that.
Comment 1 Joseph Pecoraro 2015-09-18 12:09:17 PDT
You could consider this a subtask of 143589, but I'll just consider it a duplicate. We know we need to do this, not just for arrays but all collections (e.g. Map/Set).

*** This bug has been marked as a duplicate of bug 143589 ***
Comment 2 Radar WebKit Bug Importer 2015-09-18 12:10:02 PDT
<rdar://problem/22761939>