Bug 149320 - REGRESSION(r188871): 50% regression in page load time of Wikipedia home page
Summary: REGRESSION(r188871): 50% regression in page load time of Wikipedia home page
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Myles C. Maxfield
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2015-09-17 17:19 PDT by Myles C. Maxfield
Modified: 2015-09-29 11:44 PDT (History)
3 users (show)

See Also:


Attachments
Patch (1.98 KB, patch)
2015-09-17 17:23 PDT, Myles C. Maxfield
dbates: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Myles C. Maxfield 2015-09-17 17:19:35 PDT
50% regression in page load time of Wikipedia home page
Comment 1 Myles C. Maxfield 2015-09-17 17:23:20 PDT
Created attachment 261461 [details]
Patch
Comment 2 Daniel Bates 2015-09-17 17:26:13 PDT
Comment on attachment 261461 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=261461&action=review

> Source/WebCore/platform/graphics/ios/FontCacheIOS.mm:104
> +#if __IPHONE_OS_VERSION_MIN_REQUIRED > 90000

This is inside an existing guard.
Comment 3 Daniel Bates 2015-09-17 17:26:53 PDT
Comment on attachment 261461 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=261461&action=review

>> Source/WebCore/platform/graphics/ios/FontCacheIOS.mm:104
>> +#if __IPHONE_OS_VERSION_MIN_REQUIRED > 90000
> 
> This is inside an existing guard.

Disregard this remark.
Comment 4 Myles C. Maxfield 2015-09-17 17:45:34 PDT
<rdar://problem/22559949>
Comment 5 Myles C. Maxfield 2015-09-17 17:50:26 PDT
Committed r189951: <http://trac.webkit.org/changeset/189951>
Comment 6 Chris Dumez 2015-09-28 09:59:58 PDT
Looks like a ~3.7% progression on iOS PLT on the bots.
Comment 7 Myles C. Maxfield 2015-09-29 11:44:00 PDT
(In reply to comment #6)
> Looks like a ~3.7% progression on iOS PLT on the bots.

\o/